Creating an Automatic Dormer


Reference Number: KB-00442
Last Modified: July 16, 2015

The information in this article applies to:

Home Designer Professional, Architectural, and Suite covers


QUESTION

How do I use the automatic dormer tools?


ANSWER

The Dormer tool allows you to quickly and easily place a floating or false dormer on top of a roof plane and gives you control over its style, pitch and materials.

In Home Designer Pro, there are two Auto Dormer tools that enable you to create two different structural dormer types:

  
  •   Floating Dormer:  Also known as a false dormer or fake dormer.

    In this type of dormer, all walls rest on top of the roof plane. The front of this dormer type can connect to an existing wall, but typically does not.

    Floating Dormers are designed to be placed in the middle of a roof plane and cannot be added to the roof plane if a wall is in the way. If your structure has no walls in the location you need to add a dormer, a Floating Dormer is the appropriate dormer to use.

    Note: The Floating Dormer tool is the same as the Dormer tool available in the lower Home Designer programs, including Home Designer Suite and Home Designer Architectural.


  •  Auto Dormer:  This is a true structural dormer. The dormer walls cut through the existing roof plane and connect to existing knee walls within the structure.

    When creating this dormer type, a knee wall running parallel to the main roof ridge must be present.

Once a dormer is created, it can be moved accurately using dimensions, resized, and edited as needed in the Dormer Specification dialog.  In Home Designer Pro, dormers can also be replicated so that exact copies are placed precisely in the plan and, if needed, they can be exploded into their individual parts.

Before placing either type of automatic dormer in a plan, specify the size and style of dormer that you would like in the Dormer Defaults dialog.


To set up dormer defaults

  1. Select Edit> Default Settings  from the menu, then select Dormer from the Default Settings list and click the Edit button.

    In Home Designer Pro, the Dormer Defaults dialog can be quickly accessed by double-clicking either the Auto Floating Dormer or the Auto Dormer tool.



  2. In the Dormer Defaults dialog, there are a number of settings that control the appearance of automatic dormers.

    In this article, we will only edit those that define the basic structure:



    • On the Roof panel specify the desired Pitch for the roof planes over the dormer.  The initial value is based on the default pitch set in the Build Roof dialog.

    • On the Walls panel specify the Height of the ceiling inside the dormer, measured from the floor of the room below the dormer. 

    • Check the box beside Set to Existing Ceiling to override the value in the Height field and use the ceiling height of the room below the dormer.  This option does not apply to floating dormers.  

    • Specify the desired Width of the dormer.

    • Click OK to close the dialog and apply your settings.


  3. Dormer defaults can be edited at any time to change the style of dormer that is created when the automatic dormer tools are used.  Additionally, individual dormers can be edited once they are created.




To create an Auto Floating Dormer

  1. Select Build> Roof> Build Roof  from the menu. In the Build Roof dialog:




    • Specify the desired pitch.  A minimum of 1:12 is required, but when creating a dormer, a pitch steeper than 6:12 is recommended.

    • If using Home Designer Pro check the box beside Build Roof Planes

    • Click OK to close the dialog and create a roof.
       

  2. Open the Dormer Defaults dialog as described above and specify the size and style of dormer that you would like to create.

    • Because floating dormers to not extend into the room below, Form Room Inside Dormer is not useful.


  3. Select Build> Roof> Dormer from the menu, then click within the perimeter the interior walls and also of a single roof plane in your plan.




  4. Click on an empty space in the room below the dormer to select it, then click the Open Object  edit button.  On the Structure panel of the Room Specification dialog, uncheck the box beside Ceiling over this room, then click OK to close the dialog.


  5. Select 3D> Create Camera View> Full Camera  from the menu, then click and drag a camera view to see the results in 3D.  With the ceiling removed, the floating dormer can be seen from the interior.  Notice that it builds upward from the roof plane but not downward into the room.






To create an Auto Dormer in Home Designer Pro

  1. Auto Dormers are typically built in an upper floor loft area, so select Build> Floor> Build New Floor  from the menu.  In the New Floor dialog, select the first option, then click OK.

     

    In Home Designer version 10 and newer programs, this will display the Floor 2 Defaults dialog.  Make any desired changes, then click OK to create your second floor.


  2. Select Build> Roof> Build Roof  from the menu.  In the Build Roof dialog:

    • Check the box beside Build Roof Planes.

    • Specify the desired pitch.  A minimum of 1:12 is required, but when creating a dormer, a pitch steeper than 6:12 is recommended.

    • Check the box beside Ignore Top Floor.  When you do so, the Allow low roof planes checkbox will also become checked.

    • Click OK to close the dialog and create a roof. 


       
      Ignore top floor will build roof planes that rest on the top of the exterior walls one floor down from the top floor. To build a roof that rests on knee walls, temporarily set the ceiling height of all rooms on the top floor to the desired knee wall height, build the roof, then restore the default ceiling height.  This is easiest to do before interior walls are drawn.

  3. Notice that the roof planes do not display on the top floor of your plan, but rather on the floor below.  The dashed lines that display on the top floor are ceiling indicator lines, which show you where the flat, full height ceiling meets the sloped ceiling directly under the rafters.




  4. Select Build> Wall> Interior Wall  from the menu, then click and drag an interior wall that runs parallel to the dashed ceiling indicator lines. 


  5. Click on the wall to select it, then click on one of the temporary dimensions that display to use the Move Object Using Dimension function which displays an in-line text box where you can enter in a value to move the knee wall to the desired location.

    Note: If you do not see Temporary dimensions select View> Temporary Dimensions from the menu. In prior versions this toggle was found in the CAD> Dimensions> View Temporary Dimensions menu. Temporary Dimensions will not display if there is already a dimension measuring the distance.


  6. Click on this wall to select it, then click the Open Object  edit button.  On the Roof panel of the Wall Specification dialog, check the box beside Knee Wall, then click OK.


  7. Open the Dormer Defaults dialog as described in the first section of this article and specify the size and style of dormer that you would like to create.


  8. Select Build> Roof> Auto Dormer from the menu, then click between the knee wall and the exterior wall closest to it to place a dormer at that location.




  9. Select 3D> Create Camera View> Full Camera  from the menu, then click and drag a camera view to see the results in 3D.  Notice that Auto Dormers not only build upward from the roof plane but also downward into the room.






There are a number of ways to edit an existing dormer:  In floor plan view, using the Dormer Specification dialog, or in Home Designer Pro, by permanently exploding the dormer into its individual components.

To edit an automatic dormer

  1. Automatic dormers can be moved and resized in floor plan view using the edit handles.  Click on a dormer's side wall to select it, then use the Move  edit handle that displays over the window to move the dormer to a new location.  The side handles allow you to change the dormer's width, as well.




  2. Click on the dormer to select it, then click the Open Object  edit button to open the Dormer Specification dialog.  Here you can control many aspects of the roof over the dormer - including the gutter, frieze and returns.

     

  3. In Pro, you have an option to Explode the dormer into it's component pieces. Select the dormer then click the Explode Dormer  edit button to break the dormer into its individual parts rather than a single object.  Once exploded, you can make changes to individual walls, roof planes and even the roof hole, as needed. 

    Once a dormer is exploded, it is impossible to re-block it into a single unit again.




Unlike the other components of an automatic dormer, the window can be selected individually and edited or replaced.

To edit or replace a dormer window

  1. In either floor plan or 3D views, click on the dormer window to select it, then click the Open Object  edit button.  In the Window Specification dialog, you can customize the window to meet your needs.

     


  2. In Home Designer Pro, another option is to replace the window with one from the library.  Click on the window to select it, then click the Replace from Library  edit button.


  3. In the Replace From Library dialog, click the Library button.

     


  4. In the Select Library Object dialog:

    • Browse the Windows library to locate a window that fits your needs. 

    • Click on the desired window to select it.

    • Click OK to close the dialog and return to the Replace From Library dialog.


  5. In the Replace From Library dialog, select either Replace Selected Object or Replace Identical Objects on Floor, then click OK to close the dialog and apply the change.




Many plans feature sets of matching dormers, often floating dormers.  In Home Designer Pro, the Transform/Replicate Object dialog allows you to create matching dormers quickly and easily.  Only dormers that have not been exploded can be replicated in this manner.

To replicate identical dormers

  1. Click on a dormer to select it, then click the Transform/Replicate Object  edit button.


  2. In the Transform/Replicate Object dialog:



    • Check the box beside Copy and specify how many copies you wish to make.

    • Check the box beside Move and specify the intervals at which you would like copies to be made in the text field beside the appropriate Delta

    • In floor plan view, the X Delta runs left to right across the monitor;  the Y Delta runs down to up on the monitor;  and the Z Delta corresponds to height relative to the floor platform or ground.  Changes made to the Z Delta value are not visible in floor plan view. 


    • Click OK to close the dialog and create the copies of the dormer at the specified intervals along the roof.

       
  3. Sometimes, it is easy to calculate the Move interval, while other times it is not.  If your dormers are not spaced properly after they are replicated, use temporary dimensions and the Move  edit handle to position them the correctly.



  4. Select 3D> Create Camera View> Full Overview  from the menu to see the results in 3D.