Estimating Material Costs

Reference Number: KB-00453
Last Modified: March 11, 2016

The information in this article applies to:

Home Designer Professional


Where do the materials on the Materials List come from in Home Designer Pro?


This article describes how quantity and cost estimate materials lists are generated. You will learn some of the places where materials are configured, and how to create a materials list for quantity and cost estimation. Finally, you will learn how to configure a materials list and save it.

The materials list will only be as accurate as the model you have created. The more accurate and detailed your model, the more accurate your cost estimation. Remember that in addition to price, different methods of construction may result in different material requirements.

The Materials List is based on certain assumptions which may or may not match your building style. Chief Architect Inc. makes no representation as to the accuracy or reliability of the Materials List generated by Chief Architect or Home Designer.

Always compare the Materials List with a manual take-off before providing a quote or ordering material for a job.


In the example below, you will see how a simple material cost estimation in a basic Home Designer design, a single four-walled room with 20-foot walls on each side. This simple plan is used to generate a basic quantity estimation.


To examine wall materials

  1. Use the Select Objects  tool to select one of the exterior walls, and click on the Open Object  edit button to display the Wall Specification dialog.

  2. Select the Wall Types panel.


  3. Click on the Define button to display the Wall Type Definitions dialog for the Siding-6 wall type.

  4. In the Wall Type Definitions dialog, you will see each of the wall's layers. Note that the outer layer is aluminum siding, the next layer is house wrap, the third layer is OSB, the fourth is set for framing, and the inner layer is drywall.

    From this information, right away you can see where some of your quantity and cost estimation materials come from.

    If you have any questions about the options or values that you see listed in these dialogs, click on the Help button located near the lower right of the dialog to launch the software's context sensitive Help on these features.

  5. Click Cancel to close out of the Wall Specification dialog.

Now it's time to look more closely at framing.

To examine framing materials

  1. Select Build> Framing> Build Framing  to display the Build Framing dialog.


  2. Browse through this Build Framing dialog, and navigate to the Wall panel to examine stud thickness and spacing, and go to the first floor to see where to set joist width and spacing for the subfloor.

    All of these values affect your materials.  For now, observe that these values are important considerations for cost estimation and the Materials List will use these automatically. 

After you have examined the wall materials and wall framing settings, take a look at Room Materials.

To examine room materials

  1. Use the Select Objects  tool to select the room enclosed by the exterior, and click on the Open Object  edit button to display the Room Specification dialog, and then select the Structure panel.


    • Click the Ceiling Structure Edit button to open the Ceiling Structure Definition dialog and define the layers of materials that form the ceiling platform. (Not available for rooms on Floor 0.)

    • Click the Ceiling Finish Edit button to open the Ceiling Finish dialog and define the layers of materials that form the finished ceiling surface.

    • Click the Floor Structure Edit button to open the Floor Structure Definition dialog and define the layers of materials that form the floor platform.

    • In Home Designer Pro version 9.0 and prior, these materials were located on the Materials tab.

  2. Click on the Materials panel to see entries for the materials for Moldings and Wall Coverings that are applied to the room.

  3. Now, navigate to the Moldings panel, and see a base molding is set around the base of the room by default.

In most designs these are only some of the important materials. Other designs will include roofing, windows, doors and different wall styles. For your simple example design, however, you've seen where the materials can be set, so now do a quantity estimation.

To generate a Material's List

  1. Select Tools> Materials List> Calculate Materials For All Floors .

  2. Scroll to the bottom of the Materials list, and locate the Interior Trim section, where you can see that there is 76 feet of base molding required.


  3. Also take a look at the wall board, where you can see that you require twenty-two 4' x 8' sheets of 1/2 inch Sheetrock for the walls.

    You can also see another entry for twelve 4' x 8' x 5/8 inch sheets used for the ceiling.


  4. If you scroll back up to the top of the Materials List, you can examine the General category.


    In addition to material-specific information, this cost estimation provides you with additional plan information. Here you can see the square footage for all interior walls and for ceiling surfaces.

For your cost estimation, suppose that you did not want to display the General category. In the Materials List, you have the ability to choose which categories display.


To adjust what is displayed on the Materials List

  1. Select Tools> Display Options  to display the Materials List Display Options dialog. 

    In prior versions select Tools> Display Settings> Display Options


  2. Click to remove the checkmark from the General (GN) category.

  3. Click OK to close the dialog and update the Materials List without this category present.

  4. To change the text within a category, simply double-click on the cell and the text becomes available for editing.

  5. Finally, when you select File> Close View to close the materials list, you are prompted to save it.

Using saved materials lists, you can create quantity and cost estimations for various stages of your project, or you can create estimates for small subsections of the design for remodeling purposes. For now, choose Save, name the Materials list and close the materials list.

Every saved materials list is a saved snapshot of the current state of the design.  If you save the materials list and make changes to the design, you will need to regenerate a new materials list; the previously saved materials list will not update.

Take a look at two other aspects of the materials lists –- the master list and components list.

Home Designer Pro maintains a Master List of materials that can be used with all of your plans. Here, you can store pricing, suppliers, manufacturers, descriptions and other useful information for use with materials lists you create in any plan.

To use a Master List

The Master List can be accessed by selecting Tools> Materials List> Master List .

Like the materials list, you can double-click on any material description to change it or change pricing for any material.

You can add a material from a materials list to the Master List by closing the Master List and reopening your Materials list. To reopen the materials list go to Tools>Materials List Management and select Edit. Click on the left most numbered column for that material, then selecting Tools> Update to Master.

You can update the information of a material in a materials list to use the information from your Master list by clicking on the left most numbered column for that material, then selecting Tools> Update from Master.

For additional information on the Master List, with your software open, click on the Help menu and click on Launch Help, or Contents and Index if you have an older version, and in the space provided on the Index tab, type in the keyword of Master List.

To use Components

Many architectural objects in the program, from walls to cabinets to images, have components and accessories associated with them that are calculated in the Materials List.

In addition to editing and adding information for objects and their accessories in the Materials and Master Lists, you can edit and add information directly to these objects in the Components dialog.

To modify the Components for an object

  1. In your 2D floor plan view, select Build> Cabinet> Base Cabinet  and click in the plan to place this object.

  2. Use the Select Objects  tool to select the cabinet, and click on the Components  edit button to display the Components dialog for this newly placed base cabinet.

  3. Using the check boxes, you can enable or disable the individual components, or you can double-click on entries to change their descriptions.


    Suppose that you were buying your cabinets as pre-fabricated items. In that case, your cost estimation need not include handles and other cabinet components.

    You can click on each check box, and disable all components except the pre-fabricated item number. Now when you generate your cost estimation, you'll only include the item that you will actually be buying.