Creating a Materials List for an Event


Reference Number: KB-01000
Last Modified: July 16, 2015

The information in this article applies to:

Home Designer Professional or Home Designer Architectural or Home Designer Suite or Home Designer Interiors or Home Designer Essentials or Home Designer Landscape & Deck


QUESTION

I would like to use the Materials List in Home Designer to help me plan my event. How can I do that?



ANSWER

Planning an event such as a wedding, anniversary or graduation party can require a lot of time and patience. You can use your Home   Designer software not only to help select color themes and styles for your event and decide how you will use your available space, but also to help you prepare a list of the items you will need to purchase or rent and estimate their cost.

A Materials List generates based on the current state of the plan, so  it is not necessary to wait until the plan is complete to generate a  Materials List. However, it is noteworthy that creating a materials list  will generally be one of the last steps in creating a design, as it is based on accumulating quantities of various items in your model.

Materials  Lists can be created, edited, and printed directly from the program. They can also be exported as text files for use in other programs. 

When designing a plan for an event, it is not uncommon to require many copies of the same object. Instead of placing each individual item from the Library repeatedly, you can arrange a single set of items and then copy and paste them to save a great deal of time and effort. 

 

To edit and arrange objects

  1. First, select View> Library Browser  to open the Library Browser window, then either browse to the objects that you want to use, or use the Library Search to locate them.

    Navigate to Library> Library Browser in Home Designer 2014 and prior versions. 


    • In this example we are using the Kitchen Accessories Bonus Catalog. Please see the Related Articles section below for more information on downloading additional catalogs. 


  2. Select the item you want to place, and click in plan view to place it.

    • Silverware and similar objects will automatically be placed on top of a table surface, which saves us from having to edit the Floor to Bottom height in their specification dialog after they are placed.

  3. Now that you have placed an object, it is wise to use the Select Objects  tool to select it, and click on the Open Object  edit tool to display its specification dialog. On the Materials panel, you can specify the appropriate material before making copies of it.



    • You may find it helpful to create a custom material for some purposes.

    • For example, if you want to use plasticware instead of silverware, the default material of the cutlery placed from the Library Browser will not be appropriate.


  4. Once you have made any necessary changes to the individual object, click OK to apply them and close the dialog. You can use the same procedure to place and edit any remaining objects in the arrangement of items you want.




  5. After you have completed your first arrangement of objects, in our example, silverware, plate, and glasses, you are ready to marquee select them all together and then copy and paste everything at once to a new location.


To group-select and copy/paste a group of objects


There are several ways to select multiple objects as a group. 
  •  Multiple objects can be selected by holding down either the Shift or Ctrl key when the Select Objects  tool is active and dragging a marquee around the objects to be selected. 


    The marquee-select method can be used to group-select similar object  types. To group-select multiple cabinets, for example, click the Base Cabinet  child button, hold down either the Shift or Ctrl key on your keyboard, drag a marquee, release the mouse button, and only cabinet objects within the marquee are selected. 

    Alternately, instead of dragging a marquee around a group of  objects, you can select a group of objects by adding them to the  selection set one by one. Select an object, hold down either the
    Shift or Ctrl key, and click additional objects to select them. 




    If an object is currently selected and a selection marquee is drawn around it, that object becomes de-selected. If an object is currently selected and a marquee is drawn around other objects, the original object remains selected and the other objects are added to the selection set. 

    When using the marquee-select method, both CAD and architectural objects included in the marquee are selected. To remove an object from the selection set, hold down the Shift key and click it. 

  1. Group select the objects that you would like to copy and paste in a new location using the method that you prefer. 


  2. With the group of items selected, click the Copy/Paste  edit button to copy the selected object(s) to the Windows clipboard and immediately enable the Paste  function in Home Designer.


  3. Click the Sticky Mode  edit button to remain in the current mode and place multiple copies of the selected object(s).

    For the purposes of this example, we placed four copies of the selected reception dinner arrangement on to the same table.  



    When group of objects such as the table and chair arrangement with table settings in this example is complete, you can use this same procedure to copy the entire table and the items on it, and paste copies as needed for your event.


To replace objects with different objects from the Library

If, after you have made copies of your table and chair   arrangements, you decide that you would like to change something, such as the type of chairs, but don't want to have to replace each once individually, there is a quick and easy way to do so by using the Replace from Library  edit tool.



If there are multiple instances of a library object in a plan, they can be replaced at the same time using the Replace From Library edit button in Home Designer Architectural and Home Designer Pro.

  1. While the Select Objects  tool is active, click on one of the chairs in floor plan view to select it.


    • Click the Replace From Library edit button to open the Replace From Library dialog.

       

      • Under Replacement Options, select Replace Identical Objects on Floor.

      • Click the Library button to select an item from the library to replace the chairs. 



  2. In the Select Library Object dialog:



    • Browse to and select the type of chair you would prefer.

    • Click OK to return to the Replace From Library dialog, then click OK once more.

      If existing walls and/or other objects do not allow enough room for a library object to be placed, place the library object where there is enough room and move the object into place while holding down the Ctrl key on the keyboard. 


Generating and editing a Materials List

Once you have completed making changes in the plan, we are ready to generate a materials list. Depending on your version of the software, you may have the ability to generate a materials list for the whole plan, an area of the plan, or just a single room.

  1. Select Tools> Materials List> Calculate From All Floors  to generate a Materials List for the entire model.

    In this example, we went to Tools> Calculate Materials For Room




    Materials Lists can be long, and only a portion of the list may display on your screen at one time. Use the scroll bar on the right to scroll through the complete list. Move the pointer to cells in the list to make changes.


    Any changes made to the model after a materials list is generated are not included in that list. To update the materials list, re-select Tools> Materials List> Calculate From All Floors. 




  2. You can control what objects are included in the Materials List and how they are shown. When a Materials List is open, select Tools> Display Options  to open the Material List Display Options dialog for the materials.




  3. Each plan file can be set to display materials according to their category. Check boxes for any columns you want to include. These categories appear in the ID columns of the material and Master List in the order they are presented here.

    The Materials List changes automatically to reflect these changes as soon as the OK button is selected.


    If the display of the category is suppressed, the information is still part of the materials list. If the materials list is exported, the information related to the suppressed categories is exported as well. 



  4. To change the description, or price, of an item, simply use your mouse cursor to click in the cell that contains that information, and either change, or add the text or numbers that you want to see reflected in this field.



    • After adding information to the Price column, click the Tab key on your keyboard to move to the next cell, and see that the Tot Cost column updates to show that price multiplied by the Count for the item.

    • At the bottom of each section, you will see the Subtotal update, and at the very bottom of the Materials List you can see the overall Total listed.


  5. To save a Materials List and any information you may have added, select File> Export Materials List while your materials list is open and export it as a text file, which can be further edited in other word processing and spreadsheet  programs.

If your version has the Calculate from Area  tool, you can create a materials list for just those items that are included within a rectangular Materials Polyline. In our example, it could potentially be valuable to do this for just the chairs in the wedding area, separate from the reception area.

While the materials list is a very versatile tool, and will allow you to edit virtually all fields, columns that can be edited include ID, Size, Description, Extra, Unit, Price, and Comment, you will not retain full control over all fields while working with the materials list in Home Designer.

To obtain full control over all fields, the list can be exported to a text  file for use in a different application. Additionally, it can be copied and pasted into a spreadsheet, and each individual cell modified within the spreadsheet.

The procedure used to export the Materials List to a text file, and the procedure to copy and paste it to a spreadsheet is described in the Related Articles section below. 

Note: The materials list is based on certain assumptions that may not match your building style. Home Designer makes no representation as to the accuracy or reliability of the materials list that is generated. Always compare the materials list with a manual take-off before providing a quote or ordering a material for a job.