Creating a Floor Plan with Colors and Patterns


Reference Number: KB-00074
Last Modified: April 27, 2020

The information in this article applies to:

Home Designer Professional



QUESTION

I would like to create a detailed floor plan of my structure. What are the methods available for accomplishing this task?


ANSWER

There are several ways to create a detailed floor plan in Home Designer Pro that we will discuss in this article, including:


Colored Fill Patterns and Line Styles

To be able to have a colored floor plan where the openings are easy to view and where you can use the Text tools directly to annotate and view the Room Types; simply change the colors you currently have assigned for the various items in your 2D floor plan view.

Floor plan with custom fill patterns and colors

To set the color or pattern of rooms

  1. Use the Select Objects tool to click in a room to select it, then choose the Open Object   edit tool.


  2. On the Fill Style panel of the Room Specification dialog that displays, use the Type drop-down menu to select a pattern.

    Note: Additionally, you can select the Library button to browse additional pattern options. 

  3. Set the Scale, Offset and Angle, Color, and other properties associated with the pattern.

    Fill Style panel where patterns can be specified


  4. Once you have finished making your changes, click OK to apply them and close the dialog.

Depending on the color that you have chosen for your room, you may notice the room label and other objects blend with the room color.


To change the background color for your room labels

  1. Use the Select Objects   tool to select the text of the Room Label and choose the Open Object   edit tool to display the Room Label Specification dialog.


  2. On the Fill Style panel, select the Solid option from the Type drop-down, and then click on the Color box to specify the background you want for this room label.

    Room Label Specification dialog - Fill Style panel - Solid Pattern Type and White Color

    If you want to be able to change the actual text of a Room Label (such as from Bedroom to Child's Bedroom), you can open the Room Specification dialog and type in what you want in the Room Name field on the General panel.


  3. Repeat this process until all of the room label backgrounds have been updated.

    Group selecting room labels and changing them all at once can also be done. Please see the Related Articles section below to learn more.


In some cases, we may want to change the color, or line style, that is applied to an object in our 2D floor plan view.  For example, electrical objects display as a bright red, and we may want to change their outline to black instead.


To change the line color

  1. Select Tools>Display Options  .


  2. Scroll down to the layer that you want to change, such as the Electrical layer, and then click on the Color box associated with the layer to change it.

    Layer Display Options dialog with Electrical layer highlighted and arrow over Color box


  3. Note that you can also change the line style, so if we wanted to have a dashed line instead of a continuous one, we would change this here for that layer as well.

    Note: The Layer Display Options dialog is also where we can turn off the display of certain objects. For example, if we did not want to see any of the invisible walls used to separate out sections of the plan, we could scroll down to Walls, Invisible and remove the check from the Disp column.

  4. Once you have finished making changes in this dialog, click OK to apply them to your 2D floor plan view.


Rendered Image Floor Plans

Standard Rendering Technique used in Top View Orthographic Doll House View

To create a rendered floor plan

  1. First, launch Home Designer Pro and choose to Open  the plan in which you would like to create a rendered floor plan view.


  2. Once the file is open, select 3D> Create Orthographic View> Orthographic Doll House View .


  3. Select 3D> Rendering Techniques> Standard .


  4. With the camera view still active, select 3D> Edit Active Camera and in the specification dialog that appears:

    Orthographic Doll House View Specification dialog with options checked

    • Set whether or not you want shadows to display by selecting or deselecting the Show Shadows box.

    • Check the Edge Smoothing when Idle box to smooth out the edges on the design.

    • If you would like a backdrop image to be displayed, select the backdrop of your choice on the Backdrop panel.

      Note: If the backdrop that was chosen is not being displayed, navigate to 3D> Rendering Techniques> Technique Options to open the Rendering Technique Options dialog, select the Vector View panel, place a check in the Use Backdrop Image box, then hit OK.  

    • Select OK to confirm the changes.


  5. Once all changes have been made, select 3D> View Direction> Top View.

    If you'd like to see the Terrain Perimeter in the view, navigate to Tools> Display Options and put a check in the Disp column next to the Terrain Perimeter display layer.


  6. The view can now be exported by selecting File> Export> Export Picture . Give the file a name and specify a location to save the image to.

    If you would like to be able to add text to your rendered floor plan, such as to add Room Name labels, you can choose to re-import the exported picture file into a new, blank floor plan by navigating to File> Import> Import Picture and browsing for the exported image.


While this option of a rendered floor plan provides the most realistic looking results, you will notice that it can be difficult to tell where door and window openings are located, unless you use the Cross Section Slider tool and adjust the position such that the walls above the door and window openings get cut off, as in the example below. To access the Cross Section Slider tool, navigate to 3D> Camera View Options> Cross Section Slider .

Cross Section Slider dialog with the top option selected


Vector Image Floor Plans

Your second option for creating a colored floor plan is to use the Vector rendering technique, instead of the Standard one.

Vector View Rendering Technique used in Top View Orthographic Doll House View

To create a vector floor plan

  1. First, launch Home Designer Pro and choose to Open   the plan in which you would like to create a rendered floor plan view.


  2. Once the file is open, select 3D> Create Orthographic View> Orthographic Doll House View .


  3. With the camera view still active, select 3D> Edit Active Camera and in the specification dialog that appears:

    Orthographic Doll House View Specification dialog with options checked

    • Set whether or not you want shadows to display by selecting or deselecting the Show Shadows box.

    • Check the Edge Smoothing when Idle box to smooth out the edges on the design.

    • If you would like a backdrop image to be displayed, select the backdrop of your choice on the Backdrop panel.

      Note: If the backdrop that was chosen is not being displayed, navigate to 3D> Rendering Techniques> Technique Options to open the Rendering Technique Options dialog, select the Vector View panel, place a check in the Use Backdrop Image box, then hit OK.  

    • Select OK to confirm the changes.


  4. Next, select 3D> View Direction> Top View .

    If you'd like to see the Terrain Perimeter in the view, navigate to Tools> Display Options and put a check in the Disp column next to the Terrain Perimeter display layer.


  5. The view can now be exported by selecting File> Export> Export Picture . Give the file a name and specify a location to save the image to.

    If you would like to be able to add text to your rendered floor plan, such as to add Room Name labels, you can choose to re-import the exported picture file into a new, blank floor plan by navigating to File> Import> Import Picture and browsing for the exported image.


    While this option provides the clean line drawing look for the results, you will notice that it can still be difficult to tell where door and window openings are located.



Related Articles