Creating Hip and Gable Roofs Manually


Reference Number: KB-00415
Last Modified: July 17, 2020

The information in this article applies to:

Home Designer Professional



QUESTION

How can I manually create a Hip or Gable Roof? 


ANSWER 

In this tutorial, we will show you how to set your defaults for building a roof, how to manually draw roof planes to create a hip roof, and how to manually create roof planes for a gable roof.

Home Designer Pro also allows you to create roofs automatically. You can use the automatic roof tools to create hip or gable roofs. However, in some situations, you may find it is easier to create roofs manually.


To create manual roof planes

  1. First, launch Home Designer Pro, and select File> New Plan to create a completely new, blank plan with nothing yet drawn on it.


  2. Next, set your roof defaults by selecting Build> Roof> Build Roof to display the Build Roof dialog.  

    Making sure the roof defaults are set up properly

    • Uncheck Auto Rebuild Roofs if it is checked.

    • Set the Pitch (in 12) value to 6".

    • Note that the Roof Overhang is set to 18". For this tutorial we will not be changing this, but it is important to remember for later steps.


  3. Select Build> Wall> Straight Exterior Wall and draw, in a clockwise fashion, a completely enclosed 4-wall rectangular structure.  

    Drawing a 30 by 40 foot structure

    For the purposes of this example, our structure is 30' x 40'.


  4. Select Build> Roof> Roof Plane and click and drag a baseline across the length of a wall.

    Dragging out the roof baseline across the wall

    When creating a hip roof, be sure not to draw across the entire length of the wall, as you will need space on either end for adjacent roof planes.


  5. Release the mouse button and move your cursor in the upwards direction. As you move the cursor, a preview outline of the roof plane displays.

    Moving the cursor in the upslope direction to draw out the roof plane

  6. Click inside the room to set the ridge edge of the roof plane, and complete your first roof plane.

A gable roof is created with two opposing roof planes that meet at a ridge.


To create a gable roof using manual roof planes

  1. Using the steps above, draw two opposing roof planes to create a gable roof.

    Two opposing roof planes on the structure


  2. Use the Select Objects tool to select the top edge of the bottom roof plane.

    Selecting the top edge of the bottom roof plane


  3. Click the Join Roof Planes edit button, then click on the bottom edge of the top roof plane to join to the selected edge of the first plane.

    Clicking the bottom edge of the top roof plane with Join Roof Planes tool

    Note: To use the Join Roof Planes tool, you must first identify which edges of the roof planes can extend to meet at a ridge, hip, or valley. The program will try to join the two planes along the line where they intersect whenever possible.

  4. You should now have two joined roof planes.

    Two joined roof planes


  5. Now extend the sides of each roof plane so that they extend past the exterior walls.  

    Extending the roof planes over the exterior walls

    When we select the side of one of the roof planes we can see a temporary dimension line indicating its distance from the wall.


  6. By clicking on this dimension line, we can set the side of the roof plane's distance from the exterior of wall layer using the in-line text box that displays.

    Setting the exact distance from the exterior wall to the edge of the roof plane

    • The default overhang that we saw earlier in the Build Roof dialog was set to 18".

    • If the overhang is set to 18 inches, the roof plane will be 18 inches from the outside of the wall. This is because it is being measured towards the inside.

    • If we set the overhang to zero, the edge of the overhang would exactly match the outside of the wall.

    • We want to measure 18 inches away from the exterior side, so we enter negative eighteen inches (-18") and press Enter.


  7. Repeat this process for the other side of the upper roof plane.

    Both sides of one roof plane overhanging the exterior walls


  8. You can repeat this same process for the bottom roof plane, or you can simply drag the edges to match the top roof plane. To do this, use the Select Objects tool to select the roof plane by clicking either side edge, select the Move  handle, and drag until it snaps to the corner of the other roof plane. Note the red indicator box marking the snap point.

    Changing the bottom roof plane to match the same overhang distance as the top roof plane


  9. Select 3D> Create Perspective Camera> Full Overview to see that we now have a completed, manually drawn, gable roof.

    Perspective view of the gable roof


A hip roof has roof planes built over every exterior wall in the plan that does not have another wall drawn above it.


To create a hip roof using manual roof planes

  1. We will use the existing plan from the section above, but first we will need to delete the existing roof planes in our plan by selecting Build> Roof> Delete Roof Planes .


  2. Draw manual roof planes over each exterior wall of the plan.

    Manual roof planes over every wall


  3. Click on the side of one of the roof planes to select it. Verify that you have the correct edge selected, click the Join Roof Planes  edit tool, and then click the adjacent roof plane to join them at an angle.

    Selecting one side of the a roof plane

    Joining the selected side with the adjoining roof plane side


  4. Repeat for the remaining roof planes.

    Joined all the roof planes on the sides


  5. Now, connect the ridge of the upper and lower roof planes using the Join Roof Planes edit tool.  

    Connecting the top and bottom roof planes for the ridge


  6. To connect the smaller side roof planes simply drag its edit handle until it  snaps to the intersection.

    Dragging the smaller side roof planes up to the center to create a triangular roof plane

    Finished hip roof floor plan view


  7. Select 3D> Create Perspective View> Full Overview to see that we now have a completed hip roof.

    Perspective view of the hip roof

MORE INFORMATION

More information on Automatic vs. Manual roof planes can be found within Home Designer Pro by selecting the Help menu and clicking on Launch Help  to display the software's Help menu. Click on the Contents tab and scroll down to the Roofs chapter to review the information further.