Creating Stairs in Sloping Terrain

Reference Number: KB-00498
Last Modified: July 16, 2015

The information in this article applies to:

Home Designer Professional or Home Designer Architectural or Home Designer Suite


I would like to draw a set of stairs that cuts into sloping terrain to join two sidewalks, but when I draw stairs in my plan, they do not follow the terrain or join to my sidewalks. What should I do?


You can create stairs that follow your terrain by drawing the stairs in an area defined by Retaining Walls and snapping the stairs to landings at each end.

The first step to creating stairs that follow the terrain in a plan is to create the landings that the stairs will attach to. We can define the heights of these landings to control the staircase's height, as well.

terrain stairs

To create stair landings

  1. Open the plan in which you want to create stairs in sloping terrain.

    In this example, the terrain has a single slope between two flat areas. 

  2. Select Tools> Display Options  from the menu and turn off the display of "Terrain, Primary Contours" layer.

    Note: While not strictly necessary, this will make drawing in the sloped area of the terrain easier.

  3. Select Build> Railing and Deck> Straight Deck Edge  from the menu, then click and drag to draw two rectangular deck rooms in the area of your plan where the stairs will be located.

    Do not try to draw the landing rooms precisely, make them bigger than you will need and then edit them to the correct size and position later on.

  4. Click the Select Objects  button, then click inside one of the landing rooms you just created and click the Open Object  edit button.

  5. On the General panel, specify the Room Type as Porch.

  6. On the Structure panel:

  • Specify the desired Floor height.

    The Floor height value is measured relative to the Default Floor Height for Floor 1, which is defined as 0".

    Bear in mind that this 0" value is not the same as 0" in the terrain if you have a building drawn in your plan. The program will automatically drop the terrain relative to the height of Floor 1, depending on the type of foundation that you build.

  • Uncheck Roof Over This Room, then click OK.

  • Repeat steps 4-6 with the other landing room.

  • To check the heights of your landings relative to the terrain, select 3D> Create Camera View> Elevation  from the menu, then click and drag a camera arrow parallel to the slope of your terrain and within the length of the landing.

  • If the landing rooms and terrain are not near one another, return to floor plan view and make any necessary adjustments to the landing floor heights. Depending on the requirements of your drawing, you may need to make changes to your slope, instead.

    To draw stairs between landings

    1. Select Build> Stairs> Straight Stairs  from the menu, then move your cursor to the landing with the lower Height value. Position it along the deck edge of the lower landing platform.

    2. Click and drag to the other landing's edge, then release the mouse button. A staircase will be created and will be attached to the two landings.


    3. Click on the stairs to select them, then click the Open Object  edit button. On the General panel of the Staircase Specification dialog, specify the desired width of the staircase in the Width field, then click OK.

      • In this example the staircase width is 72" (6 feet).

    4. With the staircase still selected, use its edit handles to make any desired adjustments to its position.

    5. Click the Select Objects  button, then click on each of the deck edges and move them to resize the landings so that they are the same width as the staircase.

      • You can also adjust the depth of the landing rooms, but if the landings are less than 2' in depth, the stairs may not snap to them.

    6. Select 3D> Create Camera View> Full Overview  to see the results so far. You may find that the terrain can be seen in parts of the staircase area.

    7. If the stairs do not snap to the height of the upper landing, return to floor plan view use the edit handle on the stairs top edge to nudge that edge until it bumps into the landing.


    To make sure that the terrain does not spill into the staircase area, we can use retaining walls to cut the terrain around this area.

    To create a well around the stairs

    1. Return to floor plan view and select Terrain> Terrain Wall and Curb> Straight Retaining Wall  from the menu. 

    2. Click and drag to draw three retaining walls around three sides of the stairs, leaving the base of the stairs open.

      • Draw the back wall of the well through the stairs rather than outside them.

      • Do not worry about positioning them precisely right now. Instead, draw them larger than the staircase and reposition them to ensure they snap to their desired location. 

    3. Select each retaining wall and use their edit handles to move them so that they bump up against the stairs.

      • The back wall of the well can bump up against the edge of the landing but should not extend into the landing at all.

      • The side walls should be positioned so that they are partially underneath the stairs and partially outside of them.

    4. Select 3D> Create Camera View> Full Overview  to see the results.

    5. You can use the Material Eyedropper  to apply the concrete material of the retaining walls to the treads and risers of the stairs or use the Material Painter  to apply new materials to these surfaces.