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The information in this article applies to:

QUESTION
How do I build a barrel roof, or curved roof, in Home Designer Pro?

Note: In Home Designer Pro, curved roofs must be created using multiple small
roof planes, however, the ability to model actual Curved Roof Planes is a feature
currently available in the Chief Architect Premier
(http://www.chiefarchitect.com/products/premier/) version of the software.
A free trial version of Chief Architect Premier can be requested from the website
at: http://www.chiefarchitect.com/products/trial.html
(http://www.chiefarchitect.com/products/trial.html)
Instructions for creating curved roof planes can be located in the Chief Architect
website's Knowledge Base.

BEFORE YOU BEGIN

Although the process for creating a barrel, or curved roof, is easier to quickly
accomplish using the Chief Architect Premier version of the software, you can still
create this style in Home Designer Pro using the manual roof tools.

This Article explains:
- How to use the cad tools to create a grid for calculating roof pitches.
- How to use that information to create a Barrel Style Roof
This article assumes:
- The user is proficient in the use of Home Designer Pro and its CAD tools.
- The user understands how to draw a roof plane manually.

ANSWER
Step 1: Creating the Structure
To begin, you rst need to create your structure:
1. Launch Home Designer Pro and start a New Plan

using the Default style

template.

2. Next, select Build> Wall> Straight Exterior Wall
draw a completely enclosed rectangular structure.

, and in a clockwise fashion,

For the purposes of this example, you will start your project by opening a new plan
and building a structure (using program defaults) that is 40' wide by 26' deep.

In Home Designer Pro version 9.0 and newer, the ceiling height by default will be
109 1/8".

3. If needed, you can use temporary dimensions to precisely position the walls. For
more information on this process, see the Related Articles section at the end of this
article.

4. Finally, select File> Save

, and choose to save the .plan file with a descriptive

name in an easy to find location on your computer, such as Documents.

Step 2: Creating a Cross Section/Elevation View:
Next, we will want to take a Cross Section/Elevation camera view of your newly
created structure. To do this:
1. Select 3D> Create Orthographic View> Cross Section/Elevation
then create a view from the LEFT-HAND-SIDE of the structure.

Note: The camera angle is important for understanding X, Y, and Z

and

coordinates, which you will need later to help automate your grid creation.

2. Next, select 3D> Delete Surface

to completely remove the wall layers

throughout the plan.

3. Switch to the CAD Toolbar Configuration

by selecting its button on the

toolbar.
Alternately, you can also select Tools> Toolbars> Customize Toolbars, then
selecting the TOOLS panel, highlight CAD Defaults, and then Close the Toolbar
Customization dialog.

4. From the menu, select Edit> Edit Behaviors> Edit Object Parts

.

Polyline-based objects are composed of lines and arcs that are
connected end to end. The individual edges of open and closed
polylines can be selected and edited independently of the object's other
edges when Edit Object Parts is enabled.

5. Next, CAD> Lines> Draw Line

to draw two lines vertically on the outside of the

framing layer of each of the side walls.
These will represent the framing width of the structure, and will be used later in
creation of your Rise/Run Grid.

6. With the Draw Line

tool still active, draw a new line horizontally, above the walls

and between the two vertical lines.
This will be used to represent the Wall Top Height and the Chord of the Arc you will
create to model your Barrel Roof. Ultimately, this line will become the Arc itself.
Your Cross Section/Elevation View should now be similar to that displayed below.

You know that the Chord of the Arc will be 26' (or 312"). You have yet to determine
the Roof Ridgeline Height and the Arc Radius for your Barrel Roof.

Step 3: Setting up the Grid
Now that you have started your plan, created a Cross Section/Elevation view, and
drawn in your reference lines, you are ready to begin setting up the grid.
1. First, use the Select Objects

tool to select the horizontal CAD line and use its

Move edit handle to drag it down to flush with the top of the walls.

2. Next, use the menu to select CAD> Lines> Draw Line

and draw a new

horizontal cad line at some distance above the original horizontal CAD line.

3. Now, select CAD> Dimensions> End to End Dimension

, and create a dimension

line between the lines representing the "Ridge Height" and the "Wall Top / Chord".
You will use this dimension to set the Ridge Height to 8' (or 96").

4. Extend the two "Grid" lines to the new "Ridge" height line.
This line will represent the underside of the rafter framing at the "Ridge". The
actual roof "Ridge" height will be approximately 96" plus the "Vertical Rafter Depth"
of the first Roof Plane.
Your plan should now look like the image below.

Step 4: Creating the Arc and the "Run" grid:
1. Using the Select Objects
on the Change Line/Arc

tool, select the "Wall Top / Chord" CAD line, then click
edit tool.

2. Select the triangular edit handle located in the arc itself, then drag the Arc up the
screen and snap it to the "Ridge" line.

3. Next, use the Select Objects
on the Transform/Replicate
the screen.

tool to select the "Grid" line on the left, then click
edit tool from the Edit Toolbar at the bottom of

4. Place a check mark next to Copy, and set the number of copies to 22.

5. Check Move and set the "Y" Delta - Move Distance to negative (minus) -12".
Since your "Run" distance will always be 12", you don't need to record this
information.

6. Click OK to perform the action and close the Transform/Replicate Object dialog, and
your Cross Section/Elevation View should now look like the image below.

Step 5: Creating the "Rise" grid:
Now you are ready to create your "Rise" grid.
1. Using the Select Objects

, tool, select the "Ridge" line and use the End Handle on

the left and drag it from left to right to shorten it.
Snap it to the center of the Arc.

2. Next, select CAD> Lines> Draw Line

and draw horizontal lines to the right from

the intersection points of the "Run" grid and the "Arc"

3. Repeat this process for all of the intersections.

4. Select CAD> Dimension> Manual Dimension

, and draw dimensions working

upward from the wall top.
These will be your "Rise" dimensions.

Note: You need to record the "Rise" information for each roof segment,
working from the bottom-up, for input when you create your Roof Planes.

_______________
Rise Information:
01 = 20 1/4"
02 = 15 1/2"
03 = 12 9/16"
04 = 10 5/16"
05 = 8 5/8"
06 = 7 1/4"

07 = 6"
08 = 4 7/8"
09 = 3 7/8"
10 = 3"
11 = 2 1/16"
12 = 1 11/16"
13 = 13/16"
_______________

Milestone Reached:
Nearly all of the work you have completed to this point, has been drawn in CAD. The
information you gathered will now be used to create your Barrel Roof. Before you get
started drawing Roof Planes, make the following changes:
1. Close the Cross Section/Elevation view and return to the plan.
If prompted, elect to NOT save the camera as you already have the information you
need to create your roof.

2. Select Edit> Edit Behaviors> Edit Object Parts

to uncheck this feature, turning

it back off and returning us to the standard edit behavior.

3. Next, return to the Default Toolbar Configuration

.

Step 6: Creating the Roof Planes
To begin, you will draw only one side of the Roof, and use special tools to create the
other side.
1. In floor plan view, from the menu, select Build> Roof> Build Roof

to display the

Build Roof dialog.
You will be using the "Rise" information you gathered earlier to set each individual
Roof Plane "Ridge" Height.

2. In the Build Roof dialog:

Set the Pitch to 20 1/4" in 12".
Set the Eave overhang to 8".
Set the Gable overhang to 12".

Click OK to implement the changes and exit the dialog without actually building the
roof.

It is important that the Roof Pitch for any given Roof Plane be set prior
to drawing that Roof Plane.

Draw the rst Roof Plane:
1. Select Build> Roof> Roof Plane

, then click and drag out the first roof plane,

being sure to draw the Roof Plane's Baseline on the outer edge of the Framing
Layer of the wall defining the rear of the structure.

If you are unfamiliar with what a Baseline is, within Home Designer
Pro, click on the Help menu, and select Launch Help.
In the space provided on the Index tab, type in the keyword of
Baseline. Once you see it displayed, click on the subheading
underneath it of Roofs, then click on the Display button to read the
software's Reference Manual information on this feature.

Using the Select Objects

tool, select the "Ridge" edge of the Roof Plane, and

use the Temporary Dimension to position it 12" away from the Baseline.

2. Select one side of the new Roof Plane and drag it over its corresponding "Gable
End" then use the Temporary Dimension to set the overhang to 12".

3. Do the same to the other side of the Roof Plane and its "Gable End" (Figure 07).

Draw the second Roof Plane:
1. From the menu, select Build> Roof> Build Roof

.

2. In the Build Roof dialog, set the Pitch to 15 1/2" then click OK to implement the
change and exit the dialog.

3. Select Build> Roof> Roof Plane

, and draw the second Roof Plane - Be sure to

draw the new Roof Plane "Baseline" on the Ridge edge of the first Roof Plane.

4. Select the "Ridge" edge of the new Roof Plane and use the Temporary Dimension
to position it 12" from the "Ridge" edge of the first Roof Plane.

5. Set the "Gable End Overhangs" to 12"

Draw the third Roof Plane:
1. From the menu, select Build> Roof> Build Roof

2. In the Build Roof dialog, set the Pitch to 12 9/16"

.

3. Click OK to implement the change and exit the dialog.

4. Select Build> Roof> Roof Plane

, and draw the third Roof Plane - Be sure to

draw the new Roof Plane "Baseline" on the Ridge edge of the second Roof Plane.

5. Select the "Ridge" edge of the new Roof Plane and use the Temporary Dimension
to position it 12" from the "Ridge" edge of the second Roof Plane.

Draw the fourth Roof Plane:
1. From the menu, select Build> Roof> Build Roof

.

2. In the Build Roof dialog, set the Pitch to 10 5/16".

3. Click OK to implement the change and exit the dialog.

4. Select Build> Roof> Roof Plane

, and draw the fourth Roof Plane - Be sure to

draw the new Roof Plane "Baseline" on the Ridge edge of the third Roof Plane.

5. Select the "Ridge" edge of the fourth Roof Plane and use the Temporary
Dimension to position it 12" from the "Ridge" edge of the third Roof Plane.

6. Set the "Gable End Overhangs" to 12" (Figure 8).

Complete one side of the Roof:
Continue this process of changing the Pitch in the Build Roof Dialog first, then
drawing each Roof Plane manually, and use the Temporary Dimensions to set the
"Gable Overhangs" and Ridge edge of the new Roof Planes until the last Roof Pitch
in your list has been used.
You will be at the Peak of the roof when you finish.

Again, please note that it is important that the Roof Pitch for any
given Roof Plane be set before drawing that Roof Plane.

Step 7: Completing the Roof
1. Select Build> Roof> Roof Plane

to activate this tool, then hold down the Shift

key on your keyboard, then click and drag to draw a marquis around all the Roof
Planes to group select them.

2. Click on the "Copy/Paste"

edit tool at the bottom of the screen.

3. You will notice that the edit tools have changed, so next you need to click on the
Reflect About Object

edit tool.

4. Move the cursor to the Ridge Edge at the Peak of the Roof and Click on the
dashed line that appears in bold.

5. Your roof is now complete, so select 3D> Create Perspective View> Full
Overview

to see the results.

Related Articles

Creating a Curved Barrel Roof (https://www.chiefarchitect.com/support/article/KB00649/creating-a-curved-barrel-roof.html)
Joining a Barrel Roof to a Flat Roof Plane
(https://www.chiefarchitect.com/support/article/KB-00684/joining-a-barrel-roof-to-aflat-roof-plane.html)
Setting Exact Wall Dimension Lengths (/support/article/KB-00245/setting-exact-walldimension-lengths.html)
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