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The information in this article applies to:
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QUESTION

How do | build a barrel roof, or curved roof, in Home Designer Pro?

Note: In Home Designer Pro, curved roofs must be created using multiple small roof planes, however, the
ability to model actual curved roof planes is a feature available in Chief Architect Premier

(https://www.chiefarchitect.com/products/home-design/premier/).

A free trial version of Chief Architect Premier can be requested from the website at:
https://www.chiefarchitect.com/products/trial.html (https://www.chiefarchitect.com/products/trial.html|

Instructions for creating curved roof planes can be located in the Chief Architect website's Knowledge Base


https://www.homedesignersoftware.com/
https://www.chiefarchitect.com/products/home-design/premier/
https://www.chiefarchitect.com/products/trial.html

and Training Videos.

ANSWER

Although the process for creating a barrel, or curved roof, is easier to accomplish using Chief Architect Premier,
you can still create this style in Home Designer Pro using the manual roof tools.

® This article explains how to use the CAD tools to create a grid for calculating roof pitches, and how to use that

information to create a barrel style roof.

® This article assumes the user is proficient in the use of Home Designer Pro and its CAD tools, and that they
understand how to draw roof planes manually.

Creating the Structure

To begin, you first need to create your structure.

1. Launch Home Designer Pro and start aNew Plan D

2. Next, select Build> Wall> Straight Exterior Wall , and in a clockwise fashion, draw a completely enclosed

rectangu lar structure.

For the purposes of this example, the structure drawn is 26' x 40'.
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3. If needed, you can use temporary dimensions to precisely position the walls. For more information on this
process, see the Related Articles section at the end of this article.

4. Finally, select File> Save [Ej and choose to save the .plan file with a descriptive name in an easy to find
location on your computer, such as Documents.

Creating a Cross Section/Elevation View

Next, we will want to take a Cross Section/Elevation camera view of your newly created structure.

1. Select 3D> Create Orthographic View> Cross Section/Elevation and then create a view from the left-

hand side of the structure.

Note: The camera angle is important for understanding X, Y, and Z coordinates, which you will need later
to help automate your grid creation.

2. Next, select 3D> Delete Surface g to completely remove the wall layers throughout the plan.

3. Select CAD> Lines> Draw Line/ , then draw two lines vertically on the outside of the framing layer of each

of the side walls.

Grid.

4. With the Draw Line / tool still active, draw a new line horizontally, above the walls and between the two

vertical lines.

This will be used to represent the Wall Top Height and the Chord of the Arc you will create to model your
barrel roof. Ultimately, this line will become the Arc itself. Your Cross Section/Elevation View should now be



similar to that displayed below.

2 - Draw one horizontal cad line between the
two vertical lines to represent a temporary
baseline height and to form the chord of the
arc.
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You know that the Chord of the Arc will be 26' (or 312"). You have yet to determine the roof ridgeline height
and the Arc Radius for your barrel roof.

Setting up the Grid

Now that you have started your plan, created a Cross Section/Elevation view, and drawn in your reference lines,
you are ready to begin setting up the grid.

1. First, use the Select Objects } tool to select the horizontal CAD line and use its Move edit handle to drag it
down to flush with the top of the walls.

2. Next, use the menu to select CAD> Lines> Draw Line/ and draw a new horizontal cad line at some distance

above the original horizontal CAD line.

3. Now, select CAD> Dimensions> End to End Dimension +—, and create a dimension line between the lines
representing the "Ridge Height" and the "Wall Top / Chord".

You will use this dimension to set the Ridge Height to 8' (or 96").

4. Extend the two "Grid" lines to the new "Ridge" height line.

approximately 96" plus the "Vertical Rafter Depth" of the first Roof Plane.

Your plan should now look like the image below.
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Creating the Arc and the "Run" grid

1. Using the Select Objects } tool, select the "Wall Top / Chord" CAD line, then click on the Change Line/Arc
s .
t "~ edit tool.

2. Select the triangular edit handle located in the arc itself, then drag the Arc up the screen and snap it to the
"Ridge" line.

3. Next, use the Select Objects Q tool to select the "Grid" line on the left, then click on the
Transform/Replicate [-+[ edit tool from the Edit Toolbar.

4. Place a checkmark next to Copy, then set the number of copies to 22.

5. Check Move and set the "Y" Delta - Move Distance to negative (minus) -12".

Since your "Run" distance will always be 12", you don't need to record this information.

6. Click OK to perform the action and close the dialog. Your Cross Section/Elevation View should now look like
the image below.



2 - Drag the new Arc to the desired roof "Ridge” height
¥

m— ===

al A
|
!
!

™
Yobth bl L LA L]
J#J__—-.' I T el \\x

og"

-

- &)

\ 4 - Select the"Grid" line on the left and click

\the Multiple Copy tool fromthe Edit Toolbar

| ‘atthe bottom of the screen. Set the number
of copies and type "-12" into the Y delta

) entry box. Click OK t8 initiate the changes.
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Creating the "Rise" grid

Now you are ready to create your "Rise" grid.

1. Using the Select Objects Q tool, select the "Ridge" line and use the End Handle on the left to drag it from left
to right to shorten it, making sure to snap it to the center of the Arc.

2. Next, select CAD> Lines> Draw Line/ and draw horizontal lines to the right from the intersection points of
the "Run” grid and the "Arc"

3. Repeat this process for all of the intersections.

4. Select CAD> Dimension> Manual Dimension & and draw dimensions working upward from the wall top.
These will be your "Rise" dimensions.

Note: You need to record the "Rise" information for each roof segment, working from the bottom-up, for
input when you create your Roof Planes.



liDrag the Ridge line back to the center of the Arc.
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Rise Information:

01=201/4"
02=151/2"
03=129/16"
04=105/16"
05=85/8"
06=71/4"
07 =6"
08=47/8"
09=37/8"
10=3"
1M=21/16"
12=111/16"
13=13/16"

Nearly all of the work you have completed to this point, has been drawn in CAD. The information you gathered
will now be used to create your barrel roof. Before you get started drawing roof planes, close the Cross

Section/Elevation view and return to the plan. If prompted, elect to not save the camera as you already have the
information you need to create your roof.

Creating the Roof Planes

To begin, you will draw only one side of the roof, and use specific edit tools to create the other side.

1. In a floor plan view, select Build> Roof> Build Roof @

You will be using the "Rise" information you gathered earlier to set each individual roof plane "Ridge" height.

2. On the GENERAL panel of the Build Roof dialog:



o Set the Pitch to 20 1/4" in 12".
o Set the Eave overhang to 8".

o Set the Gable overhang to12".

3. Click OK to implement the changes and exit the dialog without actually building the roof.

It is important that the roof pitch for any given roof plane be set prior to drawing that roof plane.

Draw the first Roof Plane

1. Select Build> Roof> Roof Plane m then click and drag out the first roof plane, being sure to draw the roof
plane's baseline on the outer edge of the Framing Layer of the wall defining the rear of the structure.

If you are unfamiliar with what a Baseline is within Home Designer Pro, click on the Help menu,
and select Launch Help.

In the space provided on the Index tab, type in the keyword of Baseline. Once you see it displayed,
click on the subheading underneath it of Roofs, then click on the Display button to read the
software's Reference Manual information on this feature.

2. Using the Select Objects }: tool, select the "Ridge" edge of the roof plane, and use the temporary dimension

to position it 12" away from the baseline.

3. Select one side of the new roof plane and drag it over its corresponding "Gable End," then use the temporary
dimension to set the overhang to 12".
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4. Do the same to the other side of the roof plane and its "Gable End" (Figure 07).

Draw the second Roof Plane



1. From the menu, select Build> Roof> Build Roof @

2. In the Build Roof dialog, set the Pitch to 15 1/2" then click OK to implement the change and exit the dialog.

3. Select Build> Roof> Roof Plane m and draw the second roof plane, but be sure to draw the new roof plane's
baseline on the ridge edge of the first roof plane.

4. Select the "Ridge" edge of the new roof plane and use the temporary dimension to position it 12" from the
"Ridge" edge of the first roof plane.

5. Set the "Gable End Overhangs" to 12".

Draw the third Roof Plane
1. From the menu, select Build> Roof> Build Roof @

2. In the Build Roof dialog, set the Pitch to 12 9/16".

3. Click OK to implement the change and exit the dialog.

4. Select Build> Roof> Roof Plane m and draw the third roof plane, but be sure to draw the new roof plane
"Baseline" on the Ridge edge of the second roof plane.

5. Select the "Ridge" edge of the new roof plane and use the temporary dimension to position it 12" from the
"Ridge" edge of the second roof plane.

Draw the fourth Roof Plane
1. From the menu, select Build> Roof> Build Roof @

2. In the Build Roof dialog, set the Pitch to 10 5/16".

3. Click OK to implement the change and close the dialog.

4. Select Build> Roof> Roof Plane m and draw the fourth roof plane, but be sure to draw the new roof plane's
baseline on the ridge edge of the third roof plane.



5. Select the "Ridge" edge of the fourth roof plane and use the temporary dimension to position it 12" from the
"Ridge" edge of the third roof plane.

6. Setthe "Gable End Overhangs" to 12".

Complete one side of the Roof

Continue this process of changing the Pitch in the Build Roof Dialog first, then drawing each Roof Plane manually,
and use the Temporary Dimensions to set the "Gable Overhangs" and Ridge edge of the new Roof Planes until
the last Roof Pitch in your list has been used.

You will be at the Peak of the roof when you finish.

Again, please note that it is important that the roof pitch for any given roof plane be set before
drawing that roof plane.

Completing the Roof

1. Select Build> Roof> Roof Plane m to activate this tool, hold down the Shift key on your keyboard, then click
and drag to draw a selection marquee around all the roof planes to group select them.
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2. Click on the Copy/Paste n=1 edit tool.

3. You will notice that the edit tools have changed, so next you need to click on the Reflect About Object _@}
secondary edit tool.

4. Move the cursor to the Ridge Edge at the Peak of the roof and click on the dashed line that appears. The
selected roof planes will be copied and reflected about the center Peak point of the structure.

5. Select 3D> Create Perspective View> Full Overview to see the results.



Related Articles

© 2003-2023 Chief Architect, Inc. All rights reserved // Terms of Use (https://www.chiefarchitect.com/company/terms.html) // Privacy Policy

(https://www.chiefarchitect.com/company/privacy.html)


file:///support/article/KB-00245/setting-exact-wall-dimension-lengths.html
https://www.chiefarchitect.com/company/terms.html
https://www.chiefarchitect.com/company/privacy.html

	Creating a Barrel Roof in Home Designer Pro
	QUESTION
	ANSWER
	Creating the Structure
	Creating a Cross Section/Elevation View
	Setting up the Grid
	Creating the Arc and the "Run" grid
	Creating the "Rise" grid
	Creating the Roof Planes
	Draw the first Roof Plane
	Draw the second Roof Plane
	Draw the third Roof Plane
	Draw the fourth Roof Plane
	Complete one side of the Roof
	Completing the Roof



