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QUESTION

How can | customize my toolbars to improve my workflow?

ANSWER

You can increase your productivity by customizing various settings relating to your toolbars. This article will
explain how, including:

Creating and switching between custom toolbar configurations

Creating custom toolbars

Using the Place Library Object tool

Using the Child Tool Palette setup

Using the Tool Search (Applies to Chief Architect X16, Home Designer 2025, and newer program versions)

Changing the toolbar button size
Backing up toolbars

Creating and switching between custom toolbar configurations

1. With a plan open, select Tools> Toolbars and Hotkeys> Customize Toolbars [%|from the menu.

In Home Designer, navigate to Tools> Toolbars> Customize Toolbars [%

2. Onthe Configurations panel of the Toolbar Customization dialog that displays:


https://www.homedesignersoftware.com/

[™ Toolbar Customization *

Tools Toolbar Configurations
Toolbar

Active Configuration:  Default Configuration

Default Configuration Switch To
Extended Tool Configuration
Space Planning Configuration Copy... k
Terrain Configuration R
emaove
Import...

Current Toolbars Folder: Ci/Users/joshua/Documents/Chief Architect Premier X168 Data/Toolbars/

o Click on a configuration in the list that is most similar to the custom configuration that you would like to
create.

Note: The available configurations may vary depending on the product and version you're using.

o With a configuration selected, click the Copy button.

3. Inthe New Toolbar Configuration dialog:

[™ Mew Toclbar Configuration *

MNew Name: |Cusb:|m Configuration

Cancel Help

o Type a short, descriptive name for your new configuration, then click OK.
o Your new configuration is added to the Toolbar Configuration list and is also specified as the new Active
Configuration.
4. Select the configuration you would like to have active from the list and use theSwitch To button to change to

it. When you click the Close button, your new configuration will be in use.

You can also switch configurations using the toolbar buttons or by right-clicking any toolbar and selecting the
configuration under Toolbar Configurations.



5. With your new toolbar configuration active, make any desired changes to the program toolbars.

o Existing toolbars can be moved so that they dock to the top, bottom or either side of the Chief Architect
program window, or they can float within the view window.

© You can add or remove buttons on existing toolbars or create entirely new toolbars using theCustomize
Toolbars dialog.

o You can customize the toolbars in all views - not just floor plan view.
6. When you are satisfied with the organization of your toolbars, selectFile> Exit from the menu to close Chief
Architect completely.

Closing the program will save your changes to the toolbar configuration made during this program session
in the .toolbar file created in Step 4, above.

If you have made changes to an existing toolbar configuration, such as the Default Configuration, it is
a good idea to make a copy of it. Creating a custom copy will help you protect your customization's
should you need to reinstall the program or restore your toolbar defaults.

Creating custom toolbars

1. Select Tools> Toolbars and Hotkeys> Customize Toolbars from the menu.

In Home Designer, navigate to Tools> Toolbars> Customize Toolbars [

2. Onthe Tools panel of the Toolbar Customization dialog, select an option using the View Type drop-down.

Note: The available View Types may vary depending on the product and version you're using.

o Your selection will determine not only what buttons are available in the Toolbar Buttons list, but also what
view types your custom toolbar will be present in.



[™ Toolbar Customization *

Tools View Type
Toolbar
Configurations

Plan ~

Plan
Availat Eramon VS|
3D View
Material
CAD Detail pols

Layout efaults...

Ray Trace

Dashboard

Mo View ault Set Control
q:g/ Active Defaults...

% Active Dimensicn Defaults Control

aterial Tools

IE'L Active Layer Set Control
Active View Tools v

Tool Description

3. Still on the Tools panel, browse the list of Available Toolbar Buttons and click on a toolbar button that you
would like to add to your custom toolbar.

o A description of the tool's use displays under the available buttons list.
o If the selected button is a Parent Tool you will see a small arrow > displayed to the left of the name which

can be used to expand the list of associated Child tools.

Note: If you are still unable to locate a particular tool, it may be that the feature you are looking for is
actually an Edit tool, which will only be available on the Edit Toolbar when it can be applied to a selected
object.

4. Click on a button in the list, hold down your left mouse button and drag the selected button outside of
the Toolbar Customization dialog box.

o If you drag the toolbar button to an existing toolbar, the button will be added to that toolbar when you
release your mouse button.

o If you drag the toolbar button into the drawing area, a new toolbar will be created and the button will be
placed in that toolbar.
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o This toolbar can be dragged and docked to the top, bottom or side of the Chief Architect drawing area, or it
can remain floating.



o Similarly, you can dock or undock existing toolbars to customize their locations as you wish at any time.

5. Continue adding toolbar buttons to your new toolbar as desired.

Custom All Elevation...n

[T ren [Bx *TH M

6. To remove an item from the toolbar, click and drag the item from the toolbar and drop it into the Toolbar
Customization dialog.

7. Torename the toolbar, select the Toolbar panel of the Toolbar Customization dialog, select the toolbar
from the list, and then click once on the name to rename it.

[™ Toolbar Customization *
Tools View Type
Toolbar Plan -

Configurations

Toolbars

Toolbar Name Plan Elevation 3D View Material CAD Detail Layout Ray Trace Dashboard Mo View ™

Active Default ... v v
Active Layer 5., v

Active Saved .. o

Annotate \/ \/ \/ \/
Arc Creation ...

Architectural .. + v v v

Camerasand ... v vy v
Custom Al Elevations Toolbar| NN NN IR B N N e

Custemn Tool ..  +

Edit Modes

File .. v v v v v v v v

Floor Up/Down v v v

Layout v

Materials List \/

n ra ~
Delete Reset Toolbars

8. Also on the Toolbar panel, you can choose which views you wish to see this toolbar in, by simply placing
checkmarks in the appropriate columns.

Using the Place Library Object tool
The Place Library Object ﬁﬁ | tool can be added to the toolbar and customized to place a symbol from the

library.

1. Place the Place Library Objectﬁﬂ | toolon a toolbar by dragging it from the Toolbar Customization dialog
onto the toolbar of your choice.



[™ Toolbar Customization *
Tools View Type
Toolbar Plan -
Configurations
Available Toolbar Buttons
Search: |p|ace (%] |
O.E Library Object Painter Object Mode ~
poﬁ Library Object Painter Plan Mode
E{'ﬁ Library Object Painter Room Mode
C?ﬂ Material Painting Modes
S| Place Library Object
>< Point Tools
—
font Replace Fonts...
g Road Tools v
Tool Description
Click to place the assigned library object.

2. Click the Close button to close the dialog.

3. Using the Select Objects [Q tool, click the Place Library Objectﬁﬂl_ tool that was just placed to open
the Library Object Button Specification dialog box.

4. Click the Library button to open the Select Library Object dialog.

[™ Library Object Butten Specification *

Library Object

Mone Selected
—

Button Mame

Button lcon Choices

ﬁﬁL Default Image

Browse...

Cancel Help

5. Navigate through the library to the symbol you want to place using this tool, select it, then clickOK.




In this example, we have selected the Composting Toilet.

[™ Select Library Object O *
Filters
Type to start searching... | ‘ ’ ﬁ ? ~
Folders

> El Showers ™

> [ Sinks

v [ Toilets

Bidet

Composting Toilet

Corner Toilet

Elongated Back Drain Toilet
Elongated Toilet

Lowboy Toilet

Low-Profile Toilet

One-Piece Toilet "
Details Preview
~ i A, —
Composting Toilet |Z| L2
Type: Fixtures Interior
Catalog: Core Architectural “
!

Folders: Architectural/ J |

Plumbing Fixtures ’
Toilets

Tags: o

Toolbar
% iz B

Cancel Help

6. Back in the Library Object Button Specification dialog, choose your desired Button Icon, then click OK to
return to the plan.

[™ Library Object Butten Specification *

Library Object

Library.. | Composting Toilet

Button Mame

|Composting Toilet

Button lcon Choices

ﬁﬁL Default Image
ﬁ' Automatic 1

- Automatic 2

Browse...

Cancel Help




This tool is now linked to the Composting Toilet symbol located in the library and can be selected anytime to
place this object in your plan.

Using the Child Tool Palette setup
1. Launch Chief Architect and create aNew Plan D

2. Select Edit> Preferences 5P| if you're on a Windows PC or Chief Architect> Preferences [p| if you're on a
Mac.

3. Select the Appearance panel of the Preferences dialog, and under the Toolbars section, move the radio
button to Child Tool Palette, then click OK.

_,\1 Preferences

~ {Appearance

Colors
Library Browser
Text
Pattern Editor
~ General
File Management
Folders
Ruby
Mew Plans
Unit Conversions
Time Tracker
Architectural
CAD
~ Edit
Coordinate System
Behaviors
Snap Properties
Master List
~ Render
Ray Trace
Video Card Status
Reset Options

Contextual Menus

Status Bar

Line Weights

Minimurn Display Weight:

Display
Images and Pictures:
Menus:

Color Off is:

Dialeg Previews

Material Previews

Backdrop Effect:

Toolbars

Button Size:

[ Click Twice to Display

[] Show Screen Redraw Time
Show Coordinates

L] Show Line Weights

[ Display in Color when Possible
Show lcons

@® Black and White

O Grayscale

) Standard
®) Vector View

) None
®) Blurred

(%Child Tool Palette
O Drop Down
Scale Toolbar lcons for High DPI

Pixels (Sizing Will Update on Next Launch)

Note: If the Tool Palette doesn't open automatically, navigate to View> Tool Palette from the menu.

Using the Tool Search*

*Applies to Chief Architect X16, Home Designer 2025, and newer program versions




1. Navigate to Tools> Toolbars and Hotkeys> Customize Toolbars E

In Home Designer, navigate to Tools> Toolbars> Customize Toolbars instead.

2. Onthe TooLs panel of the Toolbar Customization dialog that displays, search for or browse the list for the
Tool Search @rl button.

[™ Toolbar Customization >
Tools View Type
Teolbar Plan -

Configurations

Available Toolbar Buttons

Search: |

.:-E'\J.‘ Time Tracker Tools "
CQ;D Toggle 30 Mouse and Gamepad Mavigation

= Toggle Library Replacement Mode

m Toggle Patterns

Q Tool Search

P
L1 Trim Tools
=

o Undo

@ Update Layout Views v

Tool Description

Search for tools.

3. Click and drag the Tool Search button outside of the dialog box, and place it in your desired location. Click
Close to close the dialog.

4. You can now search for any tool in the program and a list of results will display, allowing you to quickly and
easily access the various tools within the program.

§al Cabinet Tools

@Cabinet Schedule - Schedule Tools
fT] Base Cabinet - Cabinet Tools
[}])Wall Cabinet - Cabinet Tools

2 Shelf - Cabinet Tools

g A soffit - Cabinet Tools

ffj partition - Cabinet Tools

5% Base Filler - Cabinet Tools

[HJFull Height - Cabinet Tools

] wall Filler - Cabinet Tools
Custnm Countertop - Cabinet Tocls
ﬂEFull Height Filler - Cabinet Tools
Custnm Counter Hole - Cabinet Tools
éCu:tcm Backsplash - Cabinet Tools




Changing the toolbar button size

1. Select Edit> Preferences from the menu if you're on a Windows PC, orChief Architect> Preferences
if you're on a Mac.

2. Onthe Appearance panel of the Preferences dialog, under the Toolbars section, change the value to the
right of the Button Size field, then click OK. The higher the value entered here, the larger the Toolbar buttons

will be.

In this example, the Button Size was changed from 20 pixels to 40 pixels.

_,\ Preferences

~ {Appearance

Colors
Library Browser
Text
Pattern Editor
~ General
File Management
Folders
Ruby
Mew Plans
Unit Conversions
Time Tracker
Architectural
CAD
~ Edit
Coordinate System
Behaviors
Snap Properties
Master List
~ Render
Ray Trace
Video Card Status
Reset Options

Contextual Menus

Status Bar

Line Weights

Minimum Display Weight:

Display
Images and Pictures:
Menus:

Color Off is:

Dialeg Previews

Material Previews

Backdrop Effect:

Toolbars

Button Size:

[ Click Twice to Display

[] Show Screen Redraw Time
Show Coordinates

L] Show Line Weights

[ Display in Color when Possible
Show lcons

@® Black and White

O Grayscale

) Standard
®) Vector View

) None
®) Blurred

@® Child Tool Palette
O Drop Down
Scale Toolbar lcons for High DPI

Pixels (Sizing Will Update on Next Launch)

3. When you relaunch the program, the change in button size will take effect.
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Note: An increase to the toolbar button size may result in tools no longer fitting on your toolbar. Such
toolbar buttons can be viewed by clicking on the double arrow icon on the far right of the toolbar.




After making modifications to your toolbars, you may want to back them up for transfer to another computer, or
in the case a computer or program malfunction occurs.

Backing up toolbars

The toolbars, as well as other user-specific data, is saved in the Chief Architect/Home Designer Data folder, which
is located in the Documents directory by default. This Data folder will begin with the full name and version of
your Chief Architect/Home Designer program followed by the word Data - for example, "Chief Architect Premier
X16 Data" or "Home Designer Pro 2025 Data."

The default file path for this folder on Windows may be one of the following, but may also vary depending on
your product and version:

C:\Users\ [ YOUR USERNAME ] \Documents\Chief Architect Premier X16 Data
C:\Users\ [ YOUR USERNAME ] \Documents\Home Designer Pro 2025 Data
And on macOS:

/Users/ [ YOUR USERNAME ] /Documents/Chief Architect Premier X16 Data

/Users/ [ YOUR USERNAME ] /Documents/Home Designer Pro 2025 Data

If you have moved your Chief Architect/Home Designer Data folder to a custom file location, refer to
the location you have moved it to instead. You can confirm the location of your Data folder in the
Preferences dialog. On the Folders panel, take note of the file path next to the "My Data Folder" or
"Data Folder for Current User" heading.

1. Close the Chief Architect/Home Designer program.

2. Browse into the Data folder for your program version and locate the "Toolbars" sub-folder.

3. Right-click on the "Toolbars" sub-folder and select Copy from the contextual menu.

On a Mac, hold down the Control key while clicking to initiate a right-click command. More
information about right-click commands on Apple input devices can be found in the following
Apple resource: Right-click on Mac (https://support.apple.com/guide/mac-help/right-click-

mh35853/mac#).

4. Navigate to the location in which you want to backup your toolbars to, then right-click and selectPaste.


https://support.apple.com/guide/mac-help/right-click-mh35853/mac#

Note: For safety's sake, it is best to use a strategy that utilizes a backup location somewhere other than
your local computer. Options include removable storage devices such as a USB flash drive or external
drive, a server or location on your network, or an online cloud storage service.

5. To restore the backed up "Toolbars" sub-folder, simply copy/paste the folder back into your program's Data
folder, ensuring that the original name is intact.

Do note that two folders with the same name typically can't exist alongside each other, so you may have to

overwrite the default "Toolbars" sub-folder that the program generates automatically. Take caution as any
data that's overwritten will be lost and can't be retrieved.

Related Articles

#Backing Up Chief Architect Content Using Traditional File Management (/support/article/KB-00001/backing-up-

chief-architect-content-using-traditional-file-management.html

architect-content-using-traditional-file-management.html)
# Troubleshooting Missing Toolbars (/support/article/KB-00467/troubleshooting-missing-toolbars.html
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