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Creating and Using Layout Templates

QUESTION
I would like to create and use a layout template in Chief Architect or Home Designer. How do I do this?  

ANSWER
A template *le has all of your preferred default settings, layer display options, and other *le-speci*c information

saved and waiting for you.   

You can create templates in any version of Chief Architect or in Home Designer 2026 and newer versions.

A layout template can also feature a border with your company information, logo, text macros and other details.

When you identify a *le as a template, Chief Architect refers to that *le for this information any time you open a

new layout *le.

Creating a layout template is easy and can save you a lot of time when creating a new layout *le. In this article,

we will discuss how to:

Setup the orientation and size

Setup the layout box defaults

Set default designer and client info*

*Applies to Chief Architect Premier only

Create the layout title block and border

Save and use the file as a template

Change the default layout template

Create a new layout or project

Note: Although not every setting or topic relating to a layout template is discussed in this article, it's

important to familiarize yourself with the various layout template settings that can be changed or specified.

These include: default settings, layers and layer settings, layout page information, title block and border

information, drawing sheet setup information, as well as any text, dimensions, or CAD created.
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To setup the orientation and size

1. In a new layout file, navigate to File> Print> Drawing Sheet Setup .

Set the Drawing Sheet Orientation and Size to your liking.

In most cases, the Printer Paper and Drawing Sheet sizes should be the same.

Make sure the Drawing Scale is set at a 1 to 1 scale.

Example: 1 in = 1 in

It is important not to change this, as the drawing scale is set when you send individual views to

the layout.

For more information about drawing scale as well as line weight scaling, click the Help button at the bottom

of this dialog.

Make any other desired changes, then click OK to apply your settings and close the dialog.



To setup layout box defaults

1. Navigate to Edit> Default Settings , select Layout Box, then click Edit.

2. On the LINE STYLE panel of the Layout Box Defaults dialog:

Set the Layer* the layout boxes will be created on.

Choose the line Color, Style, and Weight if the layout box borders are set to display.

If you want CAD information to stop the movement of the layout box, check the box for CAD Stops Move.

Set the Drawing Group* you want these layout boxes to display with.

*Applies to Chief Architect Premier only.

3. On the FILL STYLE panel, choose a Pattern, Scale, Offset and Angle, and Pattern Appearance if you want the

layout boxes to come in with a fill for the entire view.



4. On the LABEL panel:



Choose if you want to Suppress Label, use the Automatic Label, Specify Label, use a Callout*, or use a

Marker* for your layout box labels.

Using a Callout or a Marker will allow you to Specify details of that callout or marker respectively.

Decide if you want to display a border around the label and the alignment of the label.*

Set the Position and Orientation* of the label.

Decide what layer the label should be on.*

*Applies to Chief Architect Premier only.

5. Click OK and Done to close the dialogs and confirm the changes.

To set default designer and client information*

*Applies to Chief Architect Premier only



1. To set this information select Edit> Preferences  from the menu if you're on a Windows PC or Chief

Architect> Preferences  if you're on a Mac. In the Preferences dialog that opens, access the NEW PLANS
panel.

 To the right of Default Designer/Client Information, click Define.

Fill out the information for both the designer and the client. Once you are done filling out this information,

click OK.

Next, you can choose whether you'd like to copy this information to your newly created plans or layouts by

checking the boxes for New Plans or New Layouts which can then be reported by using macros.

Additionally you can set this information inside of a layout file itself:

Access your layout template or the file where you would like to specify this information.

Navigate to Tools> Designer/Client Information .



Fill out the information, then click OK.

2. To report the Designer/Client information in your files, you will need to use a text macro. Macros are

commands that insert dynamic information into a text box. They are available in both plan and layout files, but

are particularly useful in layouts.

In your layout template file, navigate to CAD> Text> Rich Text .

Click at your preferred location to open the Rich Text Specification dialog.

Select the Insert Macro  tool, then navigate to Global> Contact Info> Client/Designer and select the

macro that correlates to the information you would like to be reported. You can then use these macros

when creating your custom title block.

To create a layout border and title block

1. First, go to Page 0 of the layout file.

Page 0 is the Default Page Template. Items placed on this page show on every page of the layout

that is assigned to follow this Page Template. It's possible to set up more than one page template.

Please refer to the Related Articles section below for more information.

2. Using the CAD tools, create a border and title block that you want to display on each page of the layout.

3. Using Text  or Rich Text , add a company name, project information, and any other notations that you

may want to display on each page of the layout.



4. To insert a company logo, image, or PDF, select File> Import> Import Picture   or File> Import> Import

PDF .

5. After placing a text object in the layout, select the Insert Macro * tool to insert a macro.

Macros are available in both plan and layout files, and allow you to automatically insert information such as

the page number, date and time, and file name.

*Applies to Chief Architect Premier only.

You can use the Layout Page Number (%page%) macro to show the page number for each page of the

layout.

Use one of the Time or Date macros to insert the date or time in the layout to automatically let you know

when you printed this layout.

Add the file name for this layout sheet using one of the File Info text macros.

Inserting this next to the binding edge will allow you to determine which file it is or even where this set of



plans is located on your computer, should you need to reprint them in the future.

To save and use the *le as a template

1. With your layout open, select File> Save As Template , or within the Project Browser , right-click on

your layout file, and choose Save as Template from the contextual menu when you're using Project

Management.

In X16 and prior, select File> Templates> Save As Template .

Note: On a Mac, hold down the Control key while clicking to initiate a right-click command. More

information about right-click commands on Apple input devices can be found in the following Apple

resource: Right-click on Mac (https://support.apple.com/guide/mac-help/right-click-mh35853/mac).

2. In the Save as Template dialog that displays:

Check the box beside each category of object or data that you want to delete from the current file.

Check Set Template as Default for U.S. Units/Metric Layouts to use the new template as your default

template whenever you select File> New Layout .

Check Open New Layout After Saving Template* if you'd like to create a new layout right away.

*Available in Chief Architect Premier.

https://support.apple.com/guide/mac-help/right-click-mh35853/mac


Click OK.

3. Give the new layout template a short, descriptive name.

4. When using Project Management in X17 or Home Designer 2026, the template will be located in your Plan and

Layout Templates folder within the Project Browser .

In X16 and prior, or when using Traditional File Management in X17 or Home Designer 2026, click Save and the

program will automatically save the template to the program's Templates directory on your computer.

If you want to share your newly created template with a colleague or another Chief Architect user,

please see the resources located in the Related Articles section below.

To change the default layout template

You can change the default layout template that is used whenever you open a new layout *le by accessing the

program's Preferences dialog. If the "Set Template as Default for U.S. Units/Metric Layouts" box was checked in

the section above, it's not necessary to follow the instructions below as you have already set your customized

layout to be the default layout template.

1. Select Edit> Preferences  from the menu if you're on a Windows PC or Chief Architect/Home Designer>

Preferences  if you're on a Mac.

2. On the NEW PLANS panel of the Preferences dialog:



When using Project Management in X17 or Home Designer 2026, follow the steps below:

Click the Select button to the right of the Layout Template option to open the Select a Replacement

Template dialog.

If you don't see the Select button, click on the drop-down arrow next to Import and then choose Select.

In the Select a Replacement Template dialog, expand the Plan and Layout Templates folder, locate the

template you'd like to use, select it, and click OK to set it as your default template. If the layout template

you'd like to use isn't listed, it's likely that it hasn't been imported into Project Management.

To import into Project Management, click on Import

If you don't see the Import button, click on the drop-down arrow next to Select and then choose Import.

Additionally, you can use the Project Browser to import templates by right-clicking on the "Plan

and Layout Templates" section within the Project Browser and choosing "Import Template(s)".



You can also set a template as a default by right-clicking on it within the Project Browser and

choosing "Use as Default Plan/Layout Template."

In the Select a Layout Template File dialog, locate the Layout file you'd like to import, select it, and choose

Open.

Once it has been imported, repeat the initial steps above.

Click OK to close the dialog. The Project Browser will display an icon beside the default template(s), as well

as display a tooltip when hovering over the file(s).

In X16 and prior, or when using Traditional File Management in X17 or Home Designer 2026, follow the steps

below:

Click the Browse button to the right of the Layout Template text field for the unit of measurement you're

using.

If you don't see the Browse button, click on the drop-down arrow next to Edit Path and then choose

Browse.

In the dialog that opens next, browse to the location of your new layout template file, select it, then click

Open to specify this file as your default layout template.

Click OK to close the dialog.

Now, when a new layout or project is created, the file(s) specified in Preferences will be the default option.

To create a new layout or project



1. Select File> New Project  to create a new project.

In X16 and prior, or when using Traditional File Management in X17 or Home Designer 2026, select New>

Layout  instead. The file that opens will be based on the template specified in Preferences.

2. Specify a Project Name and choose your Measurement Units.

3. Check the Include Layout box, choose a Layout Template using the drop-down, make any other desired

adjustments, then click OK.

Note: The Layout Template selection will initially match the template specified in Preferences.
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Creating and Using Plan Templates (/support/article/KB-00463/creating-and-using-plan-templates.html)

Creating Custom Templates from Existing Projects (/support/article/KB-03094/creating-custom-templates-from-

existing-projects.html)

Exporting Projects and Disconnected Files (/support/article/KB-03212/exporting-projects-and-disconnected-

files.html)

Resizing a Layout Title Block and Border (https://www.chiefarchitect.com/support/article/KB-02862/resizing-a-

layout-title-block-and-border.html)

Sharing Projects in a Work Environment that is Utilizing Cloud/Network Services (/support/article/KB-

03155/sharing-projects-in-a-work-environment-that-is-utilizing-cloud-network-services.html)

Using Layout Template Pages (https://www.chiefarchitect.com/support/article/KB-03018/using-layout-template-

pages.html)
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