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Troubleshooting Slowness in Home Designer Plans

The information in this article applies to:

QUESTION
After working in my plan for a while, it seems that it starts to becomes slower, more sluggish, or experiences

more lag. Why might this behavior be occurring, and is there anything I can do to try to address the issue?

ANSWER
In this article, we will discuss the most common reasons that you may be encountering slowness in working in

your Home Designer plan -le.

Before completing these steps, please check to makes sure that any other software running on the computer or

in the background is needed, and exit any other programs that you may not need to have open while working in

Home Designer.

There may potentially be more than one cause to experiencing -le slowness in your plan, so you should review

all of the information listed below in order.
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Work on Files Locally

By far, the most common reason for slowness is working in an unsupported fashion, such as over a network

server location, external hard drive, or USB 3ash drive.
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In addition to experiencing slowness working in -les, working in this type of unsupported fashion is hazardous

because it can lead to -le corruption and data loss.

For these reasons, it is critical always to work on -les that are saved on your local hard drive. This means that you

should copy the -le from a network server, external hard drive, or USB 3ash drive location to your computer's

hard drive before opening it in the software. Then, make your changes, save the -le, exit the program, and then

copy the -le back to its network server, external hard drive, or USB 3ash drive location.

If you are working on your computer's hard drive, and are still experiencing slowness, then please continue with

the information provided in this article.

Verify System Requirements

If you are working on -les locally, the next step is to verify that your computer meets, or better yet, exceeds, the

minimum system requirements for running your version of Home Designer.

The system requirements for the current version of the software can be located

at: https://www.homedesignersoftware.com/products/system-requirements.html

(https://www.homedesignersoftware.com/products/system-requirements.html)

System requirements for prior versions can be located

at: https://www.homedesignersoftware.com/support/article/KB-01095/

(https://www.homedesignersoftware.com/support/article/KB-01095/)

If you primarily notice slowness with regards to 3D Camera views, check to see what video card is in your

system. Please see the Locating your Computer's Specifications

(https://www.homedesignersoftware.com/support/article/KB-03129/locating-your-computer-s-

specifications.html) Knowledge Base article to learn more.

If your video card only just meets the minimum system requirements, then you may want to look into replacing

it with a video card that is mentioned in our recommended system requirements

(https://www.homedesignersoftware.com/products/system-requirements.html#recommended).

Update your video card's driver by following the instructions in the Troubleshooting 3D Camera View Display

Problems in Home Designer (https://www.homedesignersoftware.com/support/article/KB-

00897/troubleshooting-3d-camera-view-display-problems-in-home-designer.html) Knowledge Base article, then

verify that the appropriate card and driver are listed in Home Designer's Preferences  under the VIDEO
CARD STATUS panel. If the incorrect card is listed in Preferences, it's possible that your system has switchable

graphics. Please see the Forcing Chief Architect Programs to Use a Specific Graphics Card in Windows 10

(https://www.homedesignersoftware.com/support/article/KB-03140/forcing-chief-architect-programs-to-use-a-

specific-graphics-card-in-windows-10.html) Knowledge Base article to learn how to configure your switchable

graphics.

If you are using multiple monitors, make sure that your system's video card fully supports this functionality.

You may experience slowness, particularly with 3D camera views as well as library and dialog previews if the

video card is taxed by three or more monitors as well as the rendering. You can test shutting the system down,

disconnecting the extra monitors, restarting the system, and then attempt to run Home Designer on a single

screen to see if speed improves.
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If you are looking into purchasing a new system and want to make sure that it offers good performance, please

view both our recommended system requirements (https://www.homedesignersoftware.com/products/system-

requirements.html#recommended) and our Chief Blog article (https://www.chiefarchitect.com/blog/computer-

for-design-and-gaming/).

Simplify Fill Styles and Patterns

Depending on your version, you may have the ability to apply Fill Styles and Patterns to objects like rooms,

closed CAD polylines, wall types, hatching, terrain objects, etc.

Try and avoid using complex fill styles and patterns extensively in your plan, as these can greatly slow down

working in floor plan view for tasks such as zooming, moving, and placing objects.

Material patterns, such as complex stone or tile patterns that appear in the Vector View rendering technique

(Cross Section/Elevation views), can slow down the generation and movement in these views.

If you must add these types of detailed CAD elements for hatching and fills to your design, make sure to do so

as one of the final steps when your plan is near completion, and expect to encounter slowness with the file

after doing so.

Slowness in 3D Views

If your design seems particularly slow with regards to 3D camera views, bear in mind that Home Designer relies

on the video card for 3D rendering and response times.

Avoid working with multiple 3D camera views open. Every time you make a change to the plan, the program

will redraw the entire model. Depending on the complexity of the design, this may take a long time.

You can see how many view windows are open by selecting the Window menu. Open view windows are listed

at the bottom of the menu.

If you are using the Generated Sky setting, keep in mind it takes into account the orientation of the sun, so if

you've set the sun to follow your camera, then the generated sky will regenerate each camera movement to

account for the new sun direction, which can cause slowness in 3D camera views.

If you have an integrated graphics chipset, which shares system memory instead of dedicated video memory of

its own, then expect camera views to generate and respond more slowly than on a system with a video card

with dedicated video memory.

Manage Displayed Layers - If you need to work in 3D views, turn off the display of any layers that are not

needed for the task to improve redraw time.

To learn more about working with layers, please see the Toggling the Display of Objects

(https://www.homedesignersoftware.com/support/article/KB-00264/) Knowledge Base article.

Manage 3D Surface Count - Avoid importing 3D objects from outside sources that have a large number of

complex surfaces, as these can significantly slow down camera views.

https://www.homedesignersoftware.com/products/system-requirements.html#recommended
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To check the number of surfaces for an imported symbol, start a new, blank plan using the default style

template. Import the symbol into that plan by itself, and take note of the Number Of Faces that displays on the

3D panel of the Fixture or Symbol Specification dialog.

Disable Auto Rebuild Options

There are several settings within the program that aJect rebuilding, which can slow down a complex plan if they

are constantly having to be regenerated after every change. For speed purposes, you may want to turn oJ these

auto rebuild settings, and only turn them back on when the plan is close to completion.

Automatically Rebuild Foundation - This setting can be accessed by selecting Edit> Default Settings>

Foundation.

Uncheck Automatically Rebuild Foundation to stop the foundation from rebuilding every time you make a

change on the first floor. Please note that you will then have to manually update the Floor 0 level, or remember

to turn the feature back on later in the design process.

Automatically Build/Rebuild Framing* - There are several settings relating to the automatic generation of

framing in Home Designer Pro, which can be accessed by selecting Edit> Default Settings> Framing in Home

Designer 2024 and prior versions, or Build> Framing> Build Framing in Home Designer Pro 2025 and newer

versions.

In Home Designer Pro 2024 and prior versions, go through every individual floor panel, starting on the

FOUNDATION, up to 1ST, 2ND, etc and uncheck the checkboxes near the top of the dialog for Automatically

Build Floor and Ceiling Framing. On the WALL panel, uncheck Automatically Build Wall Framing. On the

ROOF panel, uncheck Automatically Build Roof Framing.

In Home Designer Pro 2025 and newer versions, uncheck the Automatically Rebuild Framing box, and

ensure that all of the subcategory boxes are unchecked.

*Applies to Home Designer Pro Only.

Auto Rebuild Roofs - This setting can be accessed by selecting Edit> Default Settings> Roof.

On the ROOF panel, uncheck Auto Rebuild Roofs. Any future changes made to the plan while this setting is

disabled will not affect the roof, so you will need to either wait until the plan is nearer to completion to turn the



setting back or make manual adjustments to the roof if you're using Home Designer Pro.

Again, if these changes offer speed improvement in working with your complex plan, you will need to

remember to manually rebuild the various options, or to wait until the plan is near completion to turn the

automatic settings back on.

Home Designer Pro Only Settings

Home Designer Pro has several additional capabilities that can potentially cause slowness:

By default, picture and PDF files imported into your Home Designer Pro plan are referenced from outside of

the file. You can, however, choose the "Save in Plan" option in the Specification dialogs for both of these

referenced file types to embed them in the file. If you choose this option, it can significantly slow down working

in plan and layout files.

Home Designer Pro can send views to a separate file called a layout. When a cross section/elevation, camera

view, or overview is sent to a layout, you have the option to select Live View to make the view dynamically

linked to the plan file. You can also select for this view to Update On Demand or Update Always. Selecting

Update Always can potentially contribute to slowness in your plan. To change a view so that it only updates on

demand, select the view in your layout, then click the Open Object  edit button to open the Layout Box

Specification dialog. On the CAMERA VIEW panel, select Update On Demand, then click OK.

If you have been using a file through several versions of Home Designer, you may have unnecessary, leftover

materials that can be removed to reduce the overall size of your plan file. To purge unused materials from your

plan, select 3D> Plan Materials  from the menu to display the Plan Materials dialog. The list that displays

on the left includes all materials present in the plan. Select the Purge button to remove all unused materials

from the plan.

ADVANCED TROUBLESHOOTING
If you have completed all of the troubleshooting steps listed in this article and still have not been able to

determine the cause of the slowness in your plan, then please submit all of the following information to Chief

Architect's Technical Support team for advanced troubleshooting.

1. When you notice the slowness, take a moment to write down what you were doing. Include what views you

had open, what tools you were using, and what types of objects were being added, edited, or removed.

For example, joining two particular roof planes, modifying CAD lines, editing doors/windows while a 3D camera

view is open, rebuilding framing, etc.

2. Use the Backup Entire Plan/Layout  tool to create a folder with a copy of the file in which the error occurs,

along with all referenced files.

See Knowledge Base article: Using the Backup Entire Plan/Layout Tool to Send Files to Another User

(https://www.homedesignersoftware.com/support/article/KB-00987/using-the-backup-entire-plan-layout-tool-

to-send-files-to-another-user.html).

https://www.homedesignersoftware.com/support/article/KB-00987/using-the-backup-entire-plan-layout-tool-to-send-files-to-another-user.html


3. If you are receiving an error or warning dialog box, make sure to first search this Knowledge Base for the exact

wording of the error, or click on the Check KB button in the message if one is present, as there may be specific

information relevant to that error in another article. If you are unable to locate any additional information on

the error, make sure to attach a screenshot of the message.

See Knowledge Base article: Creating a Screenshot

(https://www.homedesignersoftware.com/support/article/KB-00326/).

4. Locate and save the program's MESSAGE LOG file.

See Knowledge Base article: Locating the Message Log

(https://www.homedesignersoftware.com/support/article/KB-02908/).

5. Export or save your SYSTEM INFORMATION.

See Knowledge Base article: Retrieving System Information to Send to Technical Support

(https://www.homedesignersoftware.com/support/article/KB-01867/retrieving-system-information-to-send-to-

technical-support.html).

6. Sign in to the Technical Support Center (https://support.chiefarchitect.com/) and create a new support case to

send to Technical Support.

See Knowledge Base article: Using the Technical Support Center

(https://www.homedesignersoftware.com/support/article/KB-00717/using-the-technical-support-center.html).

7. Give the case a short but descriptive title.

          

In the text of the ticket, type a detailed description of the problem, including the exact steps that caused the

slowness to occur if at all possible. The more detailed you are, the more likely we will be to reproduce the

issue and identify the problem.

Click the Browse button and attach the PROJECT BACKUP, SCREENSHOT,  MESSAGE LOG, and SYSTEM

INFORMATION files to your case, then Submit it.

Note: Some of the requested information may identify you, as well as specific information about your

computer, but it will also help us determine the source of the problem. Please be assured that any files

submitted to Chief Architect Technical Support will be used for troubleshooting purposes only.
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