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Creating and Using Plan Templates

QUESTION
I have a number of di#erent architectural design styles that I often use and would rather not have to set up my

default settings every time I begin a new plan that will use one of these styles. How can I do this work once and

save it for future use?  

ANSWER
In Chief Architect and Home Designer, any time you start a new project or create a new blank plan, its initial

default settings are copied from a template. In Chief Architect or Home Designer 2026 and newer, you can create

your own custom template plans to re2ect the architectural styles and materials that you use most often.

A template plan is essentially a blank plan with default settings customized to meet a particular set of design

needs. You may 5nd it helpful to create more than one template, each set up to draw a particular architectural

style. While using Traditional File Management or working in X16 and prior, It's a good idea to save all your

templates in a particular location, such as a folder in Documents or in the Chief Architect Templates directory. If

you're using Project Management in X17 or Home Designer 2026, templates are part of the "Plan and Layout

Templates" section within the Project Browser, and no additional 5le management needs to take place.

If migrating forward to the current version of Chief Architect from an older version, please make sure to follow

the instructions in the Migration Guide located in your Digital Locker.

While it's a good idea to go through all of the defaults and 5le-speci5c settings to make sure the template is setup

exactly how you need it, there are some defaults that are more critical to change ahead of time, as they can be

troublesome to change after the design is complete. It's recommended that these "Critical Defaults" are set up in

the template and reviewed before starting any plan.

Begin by selecting File> New Project , give your new project a name, then choose the Residential

Template.plan or Pro5le.plan as your Plan Template.

Using Traditional File Management in X17 or Home Designer 2026, or while working in X16 and prior instead

select File> New Plan  from the menu to open a new, blank plan using the default plan template.
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Floor and Ceiling Structure Defaults

Floor and Ceiling Height Defaults

Framing Defaults

Wall Type Defaults

Dimension Defaults

Note: Although not every setting or topic relating to a plan template is discussed in this article, it's

important to familiarize yourself with the various plan template settings that can be changed or specified.

These include: all default settings, default sets, layers, layer sets, and layer settings, saved plan views, wall

type definitions, custom text macros, and detail drawings, notes, and schedules located in CAD detail views. 

Please see the Related Articles section below for more information.

Saving & Creating

Saving the Template

Setting the Default Template

Creating a new plan or project

Floor and Ceiling Structure Defaults

The 2oor and ceiling Structure defaults consist of the layers that make up the 2oor and ceiling platforms. For

example the 2oor joists and sheathing or the ceiling joists. This is also where the Floor and ceiling 5nishes are

set.

1. Select Edit> Default Settings  from the menu to open the Default Settings dialog.

2. Expand the list for Floors and Rooms, select Floor/Ceiling Platform, and click Edit.

Note: Alternatively, Floor and Ceiling structure settings can be adjusted on a per-floor basis by

expanding the Floors and Rooms category, expanding Floor Levels, selecting the floor level you'd like to

change, and then clicking on the Edit button. In the Floor defaults dialog that appears, click on the Edit

button located beside each of the platform settings to modify them.

3. In the Floor/Ceiling Platform Defaults dialog, choose which platform settings to modify and then click the

Edit button.

Ceiling Structure typically contains just a layer for ceiling joists

Ceiling Finish* typically contains a layer for the drywall and a layer for the paint color.

Floor Finish* typically contains a layer for the floor finish as well as any layers for underlayment.

Floor Structure typically contains a layer for the floor sheathing and a layer for the floor joists. 



*In Home Designer you can only edit the thicknesses of these components.

4. In this example, the Floor Structure Edit button is clicked and in the Floor Structure Definition dialog, the

Layers, Materials, Energy Values, Structure properties, and a diagram of the floor structure is displayed.

Layers are numbered and listed from the top of the structure to its bottom.

To select a layer for editing, click on the layer to highlight it, and then click once again in the box you'd like to

modify.

For example, if you're wanting to change the material of a layer to something different, click on the material

name for a selected layer. In the image above, you would want to click on the words: OSB-Hrz. To adjust the

thickness, click on the 3/4" value specified for Layer #1.

Use the Insert Above/Below* buttons to add additional layers, use the Move Up/Down* buttons to move

layers up or down, and use the Delete* button to delete selected layers. 

*Applies to Chief Architect Premier only.

Specify the Energy Values* of the selected Floor or Ceiling Structure if desired. 

*Applies to Chief Architect Premier only.

Specify the structure’s Cavity R-Value, which is the R-value of its cavity insulator: most commonly, the



insulation between wood or metal joists.

Specify the Continuous R-Value, which is the R-value of continuous insulators such as rigid foam sheets.

Specify whether the selected layer has special structural attributes.

Check Framing to produce framing in the selected layer when framing is generated for the selected

structural assembly's type. When checked, additional framing settings are available, such as the Framing

Method, Construction, and Width.

Check Auto Detail as Insulation* to generate Insulation boxes in the selected layer when Auto Detail 

 is used in cross section views.

Check Air Gap to prevent the selected layer from displaying in 3D views or being calculated in the

Materials List.

*Applies to Chief Architect Premier only.

Once all desired changes have been made, click OK.

Floor and Ceiling Height Defaults

Many important default values that a#ect rooms are speci5ed in the Floor Defaults dialog for each 2oor in a plan.

This dialog controls important information that the program uses to create a 3D model - particularly 2oor and

ceiling heights and materials. Moldings can also be speci5ed in the Floor Defaults dialog.

Only the defaults for the 5rst 2oor of a building can be set ahead of time. The program uses the setting from the

5rst 2oor to create subsequent 2oors. When a new 2oor is created, its 2oor defaults are displayed and can be

changed at that time.

1. Select Edit> Default Settings  from the menu to open the Default Settings dialog. 

2. Expand the list for Floors and Rooms, expand Floor Levels, click on 1st Floor, and then click Edit. 

3. On the STRUCTURE panel of the 1st Floor Defaults dialog, specify the default Ceiling height for Floor 1.

Ceiling and Rough Ceiling represent framing dimensions from the bottom of the wall bottom plate to the

top of the wall top plate.

The default Floor Height for Floor 1 is set at 0".

Note: Chief Architect always defines the default height of Floor 1 at 0’-0”. This height value is

measured from the top of the subfloor and is the constant by which the heights of structural elements

in the program like walls, floors, and ceilings are measured. The heights of architectural objects can

be measured relative to this absolute height, as well. As such, this default cannot be changed.  

Finished Ceiling represents the dimension between the the floor finish and the ceiling finish.



At the bottom of the Structure panel, there is a setting for Monolithic Slab Foundation. If a

foundation plan is desired, do NOT check this setting. Instead, choose Monolithic Slab in the

Build Foundation dialog or the Foundation Defaults prior to building the foundation. If

Monolithic Slab Foundation is checked, the current Floor Structure will be replaced by a single

4" (100mm) layer of concrete with footings that can be seen in camera views only.

4. On the MOLDINGS panel:

The default template will have one molding already setup for Base Molding. 

If you want to remove the molding, choose Delete.

If you want to add additional moldings, Click on Add New.

If you want to replace the existing molding with a new one, choose Replace.

If you click on Add New or Replace, the Select Library Objects dialog will appear where you can then

browse to find a molding profile that meets your needs.



Specify the Width and Height, the Type, along with other related properties if desired.

5. When you are satisfied with your selections, click OK.

Framing Defaults

The Framing Defaults dialog allows you to specify several properties relating to 2oor, ceiling, wall, and roof

framing components, including such things as spacing, joist widths, framing materials, and plate values.

Properties for beams, posts, roof trusses, along with door and window openings can also be setup here.

1. Select Edit> Default Settings  from the menu to open the Default Settings dialog. 

2. Expand the Framing category, select Automatic Framing, and click Edit.

In X16 and prior, instead expand the Framing category, select General Framing, and click Edit.

3. On the FOUNDATION panel of the Framing Defaults dialog, specify the Spacing listed for the Subfloor for Floor

1.



In X16 and prior you can also control the Width for the Floor Structure. In X17, Home Designer 2026, and

newer, this is instead controlled in the Floor Structure, as covered above.

4. On the 1ST panel specify the Spacing and Width for the Ceiling Above Floor 1 as well as the Subfloor for Floor

2.

In X16 and prior you can also control the Width for the Floor Structure. In X17, Home Designer 2026, and

newer, this is instead controlled in the Floor Structure, as covered above.

Notice that the Floor Structure and Ceiling Structure matches what is speci5ed in the Floor/Ceiling

Platform Defaults section speci5ed earlier.

5. Specify your desired settings for the additional framing defaults located in this dialog, and then click OK.

Wall Type Defaults

The settings in the various wall defaults dialogs determine what wall types are drawn when using the di#erent

wall tools. It's import to become familiar with these settings and how they related to your style of building.

1. Select Edit> Default Settings  from the menu to open the Default Settings dialog.

2. Expand the list for Walls, select Exterior Wall, and then click the Edit button.

3. In the Wall Defaults dialog that displays, click on the WALL TYPES panel and specify the desired wall type to

be used when using this particular wall tool.

Click the Define button if you would like to create or modify a custom wall type in the Wall Type

Definitions dialog.

For more information on customizing or creating a new wall type, please see the Related Articles section

below.

In addition to specifying structural aspects of a wall, such as its framing and sheathing, you can specify

siding material such as lap siding, shingles or stucco and interior materials including paneling, finished

tongue and groove, and sheetrock.

4. Repeat Steps 2 and 3 to define the defaults for Interior Wall, Foundation Wall, Pony Wall, as well as any

other other Wall tools.

Dimension Defaults

There are several saved dimension defaults. Having multiple defaults allows you to switch between them to have

the dimensions change their behavior when you're dimensioning for di#erent views. For example, you can have

dimensions location the framing layer of the walls for your framing plans and the interior surface of the walls for



your interior design plans. Another example would be specifying a di#erent sized text style for your plot plan

versus a smaller sized text style for interior elevations. 

In Home Designer 2026 and newer you will not have di#erent dimension default sets, and will instead make

changes to your Dimension Default.

1. Select Edit> Default Settings  from the menu to open the Default Settings dialog.

2. Expand the list for Dimension, select Dimensions, and click the Edit button. 

3. In the Saved Dimension Defaults dialog that opens, the active dimension default is highlighted in the list as

well as being specified at the bottom of the dialog. 

In Home Designer 2026 and newer, skip to Step 4.

4. Select the default that needs to change and then click Edit to open the saved default. Review these setting to

verify that they meet the needs of your projects.

Access each of the LOCATE... panels to specify which objects you want dimensions to locate when using the

various Dimension tools.

Specify the desired Format on the PRIMARY FORMAT panel.

Specify the desired Text Style on the TEXT STYLE panel.

5. Repeat Step 4 for all Dimension Defaults in the template.

Saving the Template



Once the default settings for a 5le are setup to your liking, it's a good idea to save it as a template to be used for

future plans.

1. Select File> Save As Template , or within the Project Browser , right-click on your plan file, and choose

Save as Template from the contextual menu when you're using Project Management.

In X16 and prior, select File> Templates> Save As Template  instead.

2. In the Save as Plan Template dialog that displays:

Check the box beside each category of object or data that you want to delete from the current file.

Check Set Template as Default for U.S. Units/Metric Plans to use the new template as your default

template whenever you create a New Plan .

Check Open New Plan After Saving Template if you'd like to create a new layout right away.

Click OK.

3. Give the new template a short, descriptive name, then click OK.

4. When using Project Management in X17 and Home Designer 2026, the template will be located in your Plan

and Layout Templates folder within the Project Browser .

In X16 and prior, or when using Traditional File Management in X17 in Home Designer 2026, click Save and the



program will automatically save the template to the program's Templates directory on your computer.

If you want to share your newly created template with a colleague or another Chief Architect user,

please see the resources located in the Related Articles section below.

Setting the Default Template

You can change the default plan template that is used whenever you open a new plan 5le by accessing the

program's Preferences dialog. If the "Set Template as Default for U.S. Units/Metric Plans" box was checked in the

section above, it's not necessary to follow the instructions below as you have already set your customized plan to

be the default plan template.

1. Select Edit> Preferences  from the menu if you're on a Windows PC or Chief Architect/Home Designer>

Preferences  if you're on a Mac.

2. On the NEW PLANS panel of the Preferences dialog:



When using Project Management in X17 or Home Designer 2026, follow the steps below:

Click the Select button to the right of the Plan Template option to open the Select a Replacement

Template dialog.

If you don't see the Select button, click on the drop-down arrow next to Import and then choose Select.

In the Select a Replacement Template dialog, expand the Plan and Layout Templates folder, select the

template you'd like to use, and click Select to set it as your default template. If the plan template you'd like

to use isn't listed it's likely that it hasn't been imported into Project Management.

To import into Project Management, click on Import

If you don't see the Import button, click on the drop-down arrow next to Select and then choose Import.

Additionally, you can use the Project Browser to import templates by right-clicking on the "Plan

and Layout Templates" section in the Project Browser and choosing "Import Template(s)".

You can also set a template as a default by right-clicking on it within the Project Browser and

choosing "Use as Default Plan/Layout Template."

In the Select a Plan Template File dialog, locate the plan file you'd like to import, select it, and choose

Open.

Once it has been imported, repeat the initial steps above.

Click OK to close the dialog. The Project Browser will display an icon beside the default template(s), as well

as display a tooltip when hovering over the file(s).



In X16 and prior, or when using Traditional File Management in X17 or Home Designer 2026, follow the steps

below:

Click the Browse button to the right of the Plan Template text field for the unit of measurement you're

using.

If you don't see the Browse button, click on the drop-down arrow next to Edit Path and then choose

Browse.

In the dialog that opens next, browse to the location of your new plan template file, select it, and then click

Open to specify this file as your default plan template.

Click OK to close the dialog.

Now, when a new plan or project is created, the file(s) specified in Preferences will be the default option.

Creating a new plan or project

1. Select File> New Project  to create a new project.

In X16 and prior, or when using Traditional File Management in X17 or Home Designer 2026, select New> Plan 

 instead. The file that opens will be based on the template specified in Preferences.

2. Specify a Project Name and choose your Measurement Units.

3. Check the Include Plan box, choose a Plan Template using the drop-down, make any other desired

adjustments, then click OK. 

Note: The Plan Template selection will initially match the template specified in Preferences.
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