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The information in this article applies to:

QUESTION
I need to create a cross section detail in Home Designer Pro. How do I do this?

ANSWER
Using the CAD, Text, and Dimension tools, you can create a cross-section detail of your
structure.
In this example, a foundation detail will be created.

To create a cross section view
1. Select 3D> Create Orthographic View> Backclipped Cross Section

, then click

and drag a camera arrow in the direction that you want the view to show.

The camera arrow, or Line of Sight, should be perpendicular to the desired cross
section plane.

Note: The Backclipped Cross Section tool includes only the objects between
the starting point and stopping point of the cross section line.

2. Select Tools> Display Options

from the menu. In the Layer Display Options

dialog, turn on or off any layers, as needed.
In prior versions choose Tools> Display Settings> Display Options

If you wish to display framing in your cross section detail, remember that you
must first build the framing.

3. Select View> Color

. from the menu to toggle colors off.

In prior versions this setting was found by selecting Tools> Display Settings> Color
Off

4. Zoom

in on the area that you wish to detail.

5. Select 3D> Save Active Camera

from the menu.

Now we are ready to add CAD items, labels, and dimensions.

To add ll styles
1. Select CAD> Boxes> Insulation
with an insulation fill.

, then click and drag to draw a rectangular shape

If you have Object Snaps

enabled, Insulation Boxes will snap to the edges of

floor framing and wall framing.
Insulation Boxes can also be resized using their edit handles and dimensions.
If you have trouble getting the correct size, hold down the Ctrl key, or the
Command key if you are on a Mac, to allow for free movement.
Note that Boxes, Cross Boxes, and Insulation must always be rectangular in
shape.

2. Select CAD> Boxes> Rectangular Polyline
to draw a closed rectangular shape.

from the menu, then click and drag

Like Insulation Boxes, Rectangular Polylines will snap to objects and surfaces in
the view.
In this example, a Rectangular Polyline is drawn over the stem wall footing.

3. Click on the polyline to select it, then click the Open Object

FILL STYLE panel of the Polyline Specification dialog:

edit button. On the

Select "Concrete" from the Type drop-down list.
Adjust the Spacing, Angle, and Line Weight, if desired.
Then, click OK.

4. Add a second polyline, as described above, for the stem wall.

5. Draw another rectangular polyline outside of the stem wall. Using the steps
described in 4, above, and assign this polyline an Earth fill style.

6. Click on the polyline to select it

Click the Break Line

edit button.

Click along one of the polyline's edges.

A new corner edit handle is created at that location.
Click and drag that new corner handle to reshape the polyline.

7. Polyline edges can also be curved. Click on one of the polyline's edges to select it.
When an edge is selected, the square edit handle located along its length will be
larger than the square handle on the other edges.
With an edge selected, click the Change Line/Arc

edit button.

The selected edge is converted from a straight line into an arc.
Click and drag the small triangular Reshape edit handle to change the arc's

length, or click the small circular Resize handle to change its radius.

Click the Change Line/Arc

button once more to convert it from an arc into a

straight line.

8. Adjust the polyline as needed to create the desired shape.

Detail drawings rarely show the entire structure. Instead, lengthy components like
walls and oor platforms are truncated using a break line. If you were to draw your
cross section detail by hand using the CAD tools alone, you could create a break line
using a simple open polyline. Because details in Home Designer Pro are added to a
cross section of the entire structure, it may be helpful to create a closed polyline with a
solid white ll to hide unneeded portions of your cross section.

To add break lines
1. Select CAD> Boxes> Rectangular Polyline

from the menu, then click and drag

to draw a rectangle.
This polyline will be turned into a break line for the floor platform.

2. Click on the rectangle to select its top or bottom edge, then click on the temporary
dimension that displays its height.
In the inline text field, type the desired height of the polyline.

Note: If you do not see Temporary Dimensions select View> Temporary
Dimensions or if you have an older version select CAD> Dimensions>
Display Temporary Dimensions.

In this example, the height is specified as 18".

3. With the polyline still selected, use the Break Line
corner edit handles to one of its vertical edges.

edit tool to add four new

To space the breaks evenly, draw CAD lines through the polyline and
position them at regular intervals using dimension lines. Then, use
Object Snaps to add corner edit handles at the points where the lines
intersect the polyline.

4. Click and drag the two corner handles closest to the polyline edge's center point to
produce a zig-zag shape.

5. With the polyline selected, click the Open Object

edit button. In the Polyline

Specification dialog:
On the LINE STYLE panel, specify a light grey line color.
On the FILL STYLE panel, specify a "Solid" fill pattern that is white in color.
Click OK to close the dialog and apply your changes.

6. With the polyline still selected, click the Copy and Paste in Place

edit button.

This will create an exact copy of the break line polyline located directly on top of
the original.
As soon as it is created, this newly created copy will be selected.

7. With the newly copied polyline selected, click the Open Object

edit button, and

on the LINE STYLE panel of the Polyline Specification dialog, specify the default
black line color.
8. Click the Select Objects

button, then click the topmost edge of the copied

polyline.
Click the Disconnect Selected Edge
Click the Delete

edit tool.

edit tool or press the Delete key on your keyboard.

Repeat this process for the rightmost and bottom edges of the copied
polyline.

9. If you are using Home Designer Pro 2016 or older, click the Select Objects
button, then select Edit> Edit Behaviors> Edit Object Parts

from the menu.

Note: In older versions of Home Designer, when using Edit Object Parts,
selecting lines and arcs from a poilyline automatically separated those lines
and arcs, making them separate polylines.

Click on one of the non-broken edges of the copied polyline that you just created to
select it.

Click the Delete

edit tool or press the Delete key on your keyboard.

You should see the light grey polyline where the edge has been deleted.

Repeat this step to delete all three straight edges, leaving only the break line edge
displaying in front of the closed polyline with the white line color and fill.

When you are finished, remember to turn Edit Object Parts

back off.

10. Select the closed polyline with the light grey line color and change its line color to
white.

11. Click the Select Objects

button, then click and drag a rectangular selection

marquee around the two polylines.

12. Use the Move
drawing.

edit handle to position the break line polylines as needed in the

13. Use the Copy/Paste

edit tool to make copies of the two polylines if your detail

drawing requires more than one break line.

To add text
1. Select Edit> Default Settings

from the menu, and in the Default Settings

dialog:
Expand the list for Text, Callouts and Markers
Click on Rich Text and then click on the Edit button.

2. On the RICH TEXT panel of the Rich Text Defaults dialog, specify the desired font,
size and style of the text you want to use for your cross section detail.

In this example, a font size of 2" is specified.
Make sure that Align Left

is selected.

3. On the OPTIONS panel, check the box beside CAD Stops Move and then click OK to
return to the Default Settings dialog.

4. Click on Arrow and click the Edit button to open the Arrow Defaults dialog. Specify
the desired arrow style and size, and then click OK.

In this example an arrow Size of 3" is used.

5. Click OK to close the Arrow Defaults and then click Done to close the Default
Settings dialog as well.

6. Select CAD> Text> Text With Arrow

from the menu, then click once in the

drawing area to the left of the cross section detail to open the Rich Text
Specification dialog.
Type the desired information in the Text field and click OK.
A text object with a line with arrow attached is created at the location where you
clicked.

7. Click on the line with arrow to select it, then use its edit handles to point it at the
object its text describes in the cross section detail.

8. Repeat these steps to create additional text objects, as needed.

To align text objects
1. Select CAD> Lines> Draw Line

from the menu, then click and drag to draw a

vertical line through the entire height of the area where you have added fill and
other details.

2. Click on the line to select it, then move it away from your detail the distance that
you would like your text to be.

This line will serve as a temporary ledger to align your text to.

3. Click the Select Objects
Using its Move

button, then click on a Rich Text object to select it.

edit handle, drag it towards the CAD line you just drew until it

bumps into it.

4. Repeat this process to bump all of your Rich Text objects into the CAD line.

Notice that the line with arrow attached to the text adjusts its length to meet the
CAD line, as well.

5. To add corners to the lines with arrows that are aligned with one another, draw a
second line where you would like the breaks.

6. Select a line with arrow and click the Break Line

edit button.

Click on the line with arrow where it crosses the CAD ledger line you just drew.
When Object Snaps

are enabled, a red snap indicator will display when your

pointer is over the intersection.

Click once to create a new corner at that location.
With the line with arrow still selected, edit its shape as needed.

7. Repeat this process to edit all lines with arrows that intersect your ledger line.

8. When you are finished, you can select the CAD line and click the Delete
button or press the Delete key on your keyboard.

edit

Cross section details often have text on both the left and right sides of the detail. You
can repeat the steps above to create text on the right side, as well. To make a Rich
Text object right-justi ed, select it and click the Align Right

edit button.

To send the detail to layout
1. When your cross section detail is complete, select File> Save

to save your work.

If you have not done so already, be sure to select 3D> Save Active Camera

2. Select File> New Layout

from the menu to open a new layout page.

.

3. Select Window> Select Previous Tab

from the menu to return to your cross

section view.
In prior versions select Window> Previous View

4. Select File> Send to Layout, and in the Send to Layout dialog:

Specify the desired Scaling of the view.
Make sure Current Screen is selected.
Click OK.

5. Depending on the selected scale, a message may warn you that the view is too large
to fit on the layout sheet. Click OK - this may be alright, because in a moment the
view box will be resized smaller to show only the detail that you created.

To crop the view on the layout page
When you click OK to send the view to layout, it will show the entire cross section view
- not just your detail. You can easily remedy this.
1. If the layout page is not currently active, select Window> Show Layout from the
menu.

2. If you cannot see the entire cross section view in layout, select Window> Fill
Window

from the menu, or press the F6 key on your keyboard.

3. Click the Select Objects

button, then click on the cross section view to select it.

4. Using its edit handles, reduce the size of the layout view box until it only shows the
detail area.

A layout view box can be edited similar to a CAD Box, Cross Box, or Insulation box
- it can be resized and reshaped, but must always have four 90° corners.
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