Restoring Toolbars


Reference Number: KB-00113
Last Modified: April 26, 2016

The information in this article applies to:

Home Designer Professional or Home Designer Architectural or Home Designer Suite or Home Designer Interiors

QUESTION

My toolbars are missing, how can I get them back?


ANSWER

There are several reasons that you may be missing your toolbars. In this article, we will go over the most common reasons and how to resolve each one.




The most common reason for toolbars to appear to be missing is that they have been toggled off.

To toggle the toolbars back on

  1. Right-click on the blank area to the right of the Help menu to display a contextual menu.


  2. Under Toolbars, click to select the toolbar that has been toggled off to turn it back on.




  3. A check mark displays next to toolbars that are enabled.

    The toolbars that display in a given view depend on the view type. For example, the toolbars that are available in floor plan and 3D views are not available in Materials Lists.


  4. Additional steps for Home Designer Pro. Check to make sure that the tool bars are being displayed by selecting View> Toolbars  from the menu, then try resetting the tool bars by selecting Tools> Toolbars> Customize Toolbars  from the menu. On the Toolbar panel, click the Reset Toolbars button.


  5. If your toolbars do not appear to be toggled off after following these instructions, then continue on to the next section below to continue troubleshooting.



To reset the toolbar directory in Home Designer 2017* and newer versions

*Scroll down for instructions in the Home Designer 2016 and earlier versions.

  1. Select Edit> Preferences  from the menu on a Windows PC, or Home Designer> Preferences if you're on a Mac.


  2. Under the Reset Options panel, click the Reset Toolbars button.




  3. Then save your work, exit out of the Home Designer software program completely, and relaunch it.  Your Toolbars should now be restored back to their factory default settings and locations.



An alternative to Drop-Down toolbars is the Parent button and Child Tool Palette interface. Parent toolbar buttons have a blue triangle in the lower right corner. When you select a Parent button, its Child tools display in the Child Tool Palette. If the Child Tool Palette has been closed, it will open.

You can open the Tool Palette at any time, even when Drop Down tools are enabled, by selecting View> Tool Palette. When you click the Window Tools Parent button, for example, its Child buttons display in the Child Tool Palette.

By default, the Child Tool Palette is docked on the left side of the program window; but it can be undocked and moved, as well as resized and closed, just like other side windows.

If this is the toolbar that you appear to be missing, then use the steps below to restore it.

To reset the position of the Child Toolbar palette

  1. Select Edit> Preferences  from the menu on a Windows PC, or Home Designer> Preferences if you're on a Mac. 


  2. Under the Reset Options panel, click the Reset Side Windows button.


  3. Then save your work, exit out of the Home Designer software program completely, and relaunch it.  Your Child Toolbar palette should now be restored back to its factory default location.



For all Home Designer 216 and earlier versions, you must manually reset the Toolbars directory on your system if it has become corrupt or missing. 

To reset the toolbar directory in all programs in Home Designer 2016 and earlier versions

  1. Select Edit> Preferences  from the menu on a Windows PC or Home Designer> Preferences if you're on a Mac. 


  2. Under the Folders panel click the Show... under All Program Paths:

     


  3. Find the entry for User Toolbar Folder and click the Show in Explorer button. 

    For Mac, click the Show in Finder button.


  4. Right-click the Toolbars directory and choose Rename.


  5. Rename the directory to Toolbars-OLD.


  6. Quit Home Designer and reopen the program.


MORE INFORMATION

If your toolbars appear to be restored, but you are still missing a particular tool, it may be either that the tool is only offered in a more advanced version of the software, or it may instead be an "Edit" tool.

When you select an object, the edit toolbar appears. By default, it is located at the bottom of the program window, just above the Status Bar. The buttons on the edit toolbar can be used to edit the selected object(s). Which buttons display depends on the type of object selected, the current view, and how you selected the object.

The edit toolbar buttons are the same as the options in the contextual menu when you right-click on an object.


If you continue to have problems with your toolbars, or issues with following the steps outlined above, please contact Technical Support to get additional troubleshooting assistance.